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Solid Modeling and Meshing Generation using AMPSolid 

Overview 

This document describes the AMPSolid semi-automatic structured hex mesh generator. AMPSolid is based on the 
ACIS geometric engine and can be used as a standalone program and as the finite element mesh generator of the 
AMPS finite element simulation programs. 
This document has three goals. First, this document provides an overview of the features of AMPSolid. Second, this 
document provides a reference for using those features in constructing models and FEA meshes. Third, this document 
includes a reference portion that serves as online, context-sensitive help. Each reference topic provides an overview 
of the command, followed by a detailed reference section. This online reference manual servers as the documentation 
to AMPSolid, and is also available as hard copy that can be purchased from AMPS Technologies Company. 

 

Introduction to Mesh Generation 

AMPSolid provides a couple of different mesh generation methods to generate finite element meshes. For 2D and 3D 
shell geometry, the complete automatic meshing engine can generate triangular, quad or mixed meshes with density 
controls.  For 3D volume meshing, after the initial surface triangular meshes are generated, both automatic 
tetrahedron and hexahedron can be generated using a Delaunay algorithm. Alternatively, for high quality hexahedron 
meshing, AMPS Technologies Company’s FlexMesh™ technology can also generate a pure hexahedron for any solid 
model. The term "FlexMesh" is derived from the "Flexible Cellular" mesh generation technique implemented by 
AMPSolid. 
In AMPSolid, a mesh is created in two stages. It is necessary to have a surface geometry if a 2D or a 3D shell meshes 
are desired. For volume tetra or hexa meshing, it is required to construct a solid model or by either importing one from 
an ACIS SAT (Save as Text) file or building one in AMPSolid. It is possible to generate finite element meshes without 
using any solid model or surface in AMPView module, but it is not as convenient as the automatic meshing abilities in 
AMPSolid. 
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File Options 

New (File menu) 

This option initializes the AMPSolid program and creates a new model workspace. 

Use Model History (File menu) 

Use this option to be able to Undo operations after saving and loading a model. For the Undo/Redo history to be 
available, the model must first be saved and loaded with Use Model History checked. If the model is saved without 
Use Model History checked, the Undo/Redo history is not available the next time the file is opened. 

Append ACIS Model (File menu) 

This option appends an ACIS model by opening a SAT file and adding the geometric entities that it contains to those in 
the current workspace. Immediately after being appended, the new geometric entities are selected and can be moved 
to a different location in the model using the Edit>Translate command. 
To use this option: 
a. Select this option from the File menu. 
b. Use the Windows Browse dialog to navigate to and open the file in the standard manner. 

File Format (File Menu) 

 
This menu controls the version of the ACIS file format to be used. Since most CAD/CAE vendors may still uses older 
version of ACIS kernel in their product, to maintenance compatibility, this option will control the ACIS version of file 
format when saving the model. A dialog box will pop up t allow the selection of the available ACIS version to use. 

Input FlexMesh (File menu) 

This option read the selected FlexMesh file to the pre-selected solid entity.  This is usually used to read a FlexMesh 
model back so it can be used to continue a previous unfinished meshing section. 

Save FlexMesh (File menu) 

This option writes out the current FlexMesh model to the file associated with the FlexMesh data. If a FlexMesh file is 
not already associated with the current FlexMesh data, the user is prompt to specify a file to be associated with that 
data in the current workspace. 

Save FlexMesh As (File menu) 

This option enables you to save the current FlexMesh data to a new file and then associates that file with the 
FlexMesh data for any future save operations. 
 

Export Mesh 

The Export Mesh command allows you to generate the files necessary to set up a FEA problem using AMPView. 
Based on your method of mesh creation, the element type (2-D or 3-D) should already be specified and cannot be 
changed. The steps for exporting a mesh are: 
1. Complete the mesh using the AutoMesh menu or the FlexMesh menus. 
2. Select Files>Export Mesh to bring up this dialog. 
3. If 2nd order elements are desired, select Generate 2nd Order Lagrangian Elements. 
4. If creating 2D elements in the xy plane, Uncheck Generate 3-D Shell Elements. 
5. Click OK, and enter a filename in the next dialog for the AMPS FEA files (.dat, .fe, .geo) 
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Use current .dat if mesh renamed and no .dat option (Default checked) 
After the first analysis of a model, it is informative to reanalyze the model using a different mesh. It is also useful to use 
a different name for the 2nd analysis so that the results can be easily compared. If this option is checked, and you 
export a new mesh using a different name for which no .dat file exists, the .dat file (FEA data) for the current model is 
copied for the new model so that forces and boundary conditions can be reused. 
If this is not checked and you save the mesh under a different file name that doesn’t have a .dat file, a minimum .dat 
file is created with geometry type (2D, Shell, 3D etc.) information but no FEA material or boundary condition 
information. 
If a .dat file already exist for the target mesh file name, you are given an option to use that file regardless of this 
setting. 
Generate 2nd Order Lagrangian Elements 
Whether you are generating 2D, 3D or shell mesh, you have the option to generate the 2nd order Lagrangian family 
elements.  If this option is not activated, the default 1st order elements are generated. 
Generate 3-D Shell Elements (Uncheck for 2D) 
If you generated a 2D or Surface mesh, you have the option of generating either a 2D mesh (the model must be on the 
global XY plane) or a 3D shell mesh (the grayed out "Generate 3-D Shell Elements" choice will be active). 
If you used FlexMesh to create the mesh 
Create the Cell mesh by completing FlexMesh step 3. Or if you are performing FlexMesh 2D task, finish the 2D or shell 
meshing. 

Export Mesh Details 

Other than generating the generic *.fe finite element data file defining nodes and elements, AMPSolid also generates 
an initial AMPSol finite element model definition file *.dat and a geometry database *.geo file. These two files are used 
for AMPSol  finite element model’s system control, material definitions, h-/p-adaptivity, boundary conditions, and 
geometry connection to the solid model.   For more information about these files, please consult the on-line reference 
manual in AMPView. 
The Export Mesh option enables you to save your mesh once it has been generated. You can save your mesh after 
the FlexMesh3D’s FlexMesh Step 3 has been completed automatically or manually, or you have finished the FlexMesh 
2D/Shell mesh generation. 
AMPSolid uses OLE automation to invoke a MeshSvr server that is used to write the Finite Element mesh. Separating 
the application used to write the mesh from the basic AMPSolid application makes it easy for you to automatically 
invoke specialized mesh generation utilities for use with AMPSolid. When a version of MeshSvr is registered into your 
system, and it is activated, it will show up the ID with it’s proper title as below. 
AMPSolid includes the sample MeshSvr project that was created using the Microsoft Visual C++ wizard to implement it 
as a full stand-alone server. This server outputs mesh data in generic format currently formatted for AMPSol 
processor, and can easily be modified to export mesh data in other FE formats.  For additional information of exporting 
the mesh to other popular commercial FEA codes, please contact AMPS Technologies Company for available version 
of MeshSvr server for different FEA codes. 
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AMPView FEA Pre/Post (File menu) 

This option enables you to activate AMPS pre-/post-processor AMPView.   You must have generated the mesh data 
using the Export Mesh option before you can use AMPView for F.E. analysis. The AMPView module expects the 
model definition data file with the extension "dat", and the finite element mesh file with extension "fe", and the 
geometry database file in file with extension "geo". 

IGES Import and Export (File menu) 

The IGES data file can be imported from other CAD/CAE systems provided they conform to the IGES 1.0 to 5.3, ANSI 
Y14.26M-1981, ASME/ANSI Y14.26M-1987, or ASME Y14.26M-1989 specifications.  Since most IGES data are 
generally written to convey the geometry entities such as lines, curves and surfaces, and not specific to solid objects, 
an optionally conversion of the enclosed surfaces into a volume containing solid is provided.  
After an Import or Export operation, the translation results are recorded in a file with the original IGES file, but with file 
name extension "log". 
 
File>IGES>Import 
This option will strictly read the IGES data contained in the selected file and translate them into the corresponding 
graphic entities in AMPSolid.  If an item is not recognized, it will be discarded.  The user will be prompted to view the 
translation results. 
File>IGES>Import and Convert 
If the IGES data file contains only watertight surfaces information corresponding to a single solid entity, this option will 
automatically try to collected these surfaces and convert them into a single solid entity.  Sometimes, the data file 
contains surfaces or other IGES entities corresponding to multiple bodies or other extra data.  If solid body entities are 
desired, the user can selected the corresponding surfaces of each body, and uses the stitching tool under 
"Geometry>SheetBody>Stitch_SheetBodies/Faces_into_Body" to convert the watertight surfaces into a solid body. 
File>IGES>Export Selected 
This will write out an IGES file corresponding to the selected items. The user will be prompted to view the translation 
results. 

Print, Print Preview, Print Setup (File menu) 

These options enable you to print the current image on the screen to a system printer. Various options can be set in 
the Print Setup menu, which includes a preview capability. 
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Edit Options 

Undo (Edit menu) 

The Undo command can be repeatedly applied to undo the last entity construction or modification. If Use Model 
History is checked when a model is saved and loaded, you may undo entity operations that were performed in a 
previous session. 
 
The WCS is independent of the entity undo command. 
To retrieve a previous WCS, use the WCS Dialog button on the WCS toolbar and click the Previous WCS button until 
the desired WCS appears and click OK. 
 
The Meshing is independent of the entity undo command. 
To undo AutoMesh operation, you can use AutoMesh>Reset Mesh to delete the current mesh, and then re-construct a 
new mesh. 
 
FlexMesh/Solid steps 2 and 3 can be undo using the FlexMesh/Solid>Undo step 2 or 3 command. 
 
 

Redo (Edit menu) 

The Redo command can be repeatedly applied to undo the last series of undo operations. See Undo for more 
information on undoing operations in AMPSolid. 
 
 

Cut, Copy and Paste (Edit menu) 

These three functions are implemented using the OLE Clipboard uniform data transfer capability. When an entity 
(body, face, edge or vertex) is cut or copied from a AMPSolid model, it is automatically placed on the clipboard. It can 
then be retrieved from the clipboard by the paste function. These three functions allow convenient model modifications 
using the clipboard as a temporary storage location. These functions can also be used to transfer entity data between 
ACIS compatible applications. Most other ACIS applications in Windows provide a similar cut, copy and paste feature. 
Once the data is placed on the clipboard from any ACIS application, that data can be imported into any other ACIS 
application by pasting it from the clipboard. 

Delete (Edit menu) 

This function mainly deletes the selected entity or entities without creating a backup copy. Once it is cleared, the 
deleted entities can not be recovered. 
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Graphic User Interface 

Windows Environment 

AMPSolid uses several windows for display, messaging, and cursor control, and is sensitive to the state of the active 
window - the window in which your mouse cursor is currently located. By default, AMPSolid1 is the name of the work in 
progress, or workspace, window. This is the main window for all graphic display. The messaging window is a text-
based dialog window that keeps the user informed of the results of operations executed during the current session. A 
third window, the Status and Cursor Control window, is usually shown on the screen. This window enables the user to 
manage various cursor snapping states and state variables. Clicking the cursor in a window activates that window.  To 
obtain additional visible screen space, you can close any of these windows by clicking the "X" mark in the upper right 
corner of the window frame, and can subsequently use the Option or Window menu to open them again.  

 
The window environment is controlled by the state of the options on the Window menu.  The options on this menu are 
context-sensitive based on the state of the active window, and will be automatically enabled or disabled as appropriate 
to prevent erroneous choices. Like most Windows applications, AMPSolid, uses a centralized file to save window 
state, size, position, and color settings, as well as various user settings. This file, located in the main Windows 
directory, is named "AMPSolid.ini."  Deleting this file resets AMPSolid's user configuration. 
 
By default, AMPSolid starts up as shown below. The top menu begins with the File menu at the left and ends with the 
Help menu at the right.  When you select a menu, a help message summarizing the options on that menu is displayed 
at the bottom of the status bar area. You can press the F1 key at any time to obtain more detailed help.  You can also 
use the Help icon (an icon with a question mark and arrow) to display additional help information about any menu or 
dialog box entry. 
 

Grid Controls (Edit>Grid Snap Control…) 

A two-dimensional grid can be created to help in the generation of geometric entities.  
Selecting the grid control option displays the following dialog box: 
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Once you have made any desired changed to the grid controls, click Close to close the dialog. You can subsequently 
modify the grid controls by reselecting the Edit>Grid Snap Control… menu item. 
When the grid display is active, the grid is always displayed for the current XY plane of the WCS. 
The Snap Intervals are also used for the Keyboard Shortcuts to move selected entities or the WCS axis. 
 

Smart Snap Grid 

AMPSolid’s smart snapping grid controls provide an alternate way of specifying dimensions and positions when you 
are creating geometric entities. You can control the positioning and display of grid lines by using the options on the 
"Grid Snap Control" menu to enter grid and snap intervals. To activate snapping, check the SCC windows "grid" 
snapping box. Once snapping is active, depressing the control key when moving the mouse activates the snap 
function. The current cursor position is then displayed in the coordinate display box at the bottom of the AMPSolid 
window and in the SCC Position State field. AMPSolid projects mouse movement into the WCS working plane (formed 
by the WCS 1 and 2 axes) when grid snapping is desired. This provides easy-to-use 3D controls for navigation.  
Changing the WCS orientation gives you detailed control of 3D snapping in any direction. 

Toggle Commands 

Most of the Toolbar commands (except the Selection and Flexmesh commands ) are toggle commands.  If a toggle 
command is selected while active, the command is turned off and the last non-toggle command is restored. Using 
toggle commands you can use dynamic zoom, pan and rotate during construction commands to change the view. 
When you are finished changing the view, click on the active toggle command on the toolbar (or select it from the 
menu) and the toggle command is turned off and you can continue with the construction. Here’s an example: 
Changing the view while creating a line: 
a) Select Create>Line to start creating a line 
b) Enter the first point 
c) Select View>Camera>Dynamic Rotate or click on the Dynamic Rotate toolbar icon to enter dynamic rotate 

mode. 
d) Drag the mouse with the left button down to rotate the view 
e) Select View>Camera>Dynamic Pan or click on the Dynamic Pan toolbar icon to enter dynamic pan mode. 
f) Drag the mouse with the left button down to pan the screen 
g) Select View>Camera>Dynamic Pan or click on the Dynamic Pan toolbar icon while it is active (checked for a 

menu item, depressed for a toolbar icon) to turn off the toggle operation. 
h) Enter the second point to complete the line. 
 
Here are some rules about using toggle commands: 
1) You can use any number of toggle commands and still return to the non-toggle construction command by toggling 

the last toggle command off.  
2) You don’t need to turn off the last toggle command before using another toggle command. 
3) Turning off the last toggle command returns you to the last non-toggle (usually construction or selection) 

command before the series of toggle commands were used. 
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4) If you use a non-toggle command (like selection or another creation command), a pending non-toggle command 
is aborted. If the following sequence of commands were used: Create>Line, enter point, Dynamic Zoom, Select 
Edge. The select edge would abort the pending Create>Line command the same as if the Dynamic Zoom 
command were not used. 

 
Some of the toggle commands are: Dynamic Pan, Dynamic Rotate, Dynamic Zoom, Zoom Window, WCS toolbar 
commands and the measure commands. 
The right mouse button can be used to toggle off the Dynamic Pan, Rotate and Zoom commands and restore the 
previous non-toggle command. 

Keyboard Shortcuts 

Keyboard shortcuts are available for 

• Snapping to a vertex 

• Moving selected entities 

• Moving the WCS 

• Rotating the WCS 
 
Snapping to a vertex (CTRL Right Mouse) 
While CTRL (snap) is held down, press the right mouse button down causes the snap cursor (+) to snap to the nearest 
vertex regardless of the current snap mode. When the desired vertex is selected, release the right mouse button to 
enter the point. To abort the operation after the Right Mouse button is pressed, release the CTRL button to exit snap 
mode before releasing the right mouse button. 
 
Moving selected entities (Translation shortcut keys) 
The arrow keys and the PgUp/PgDn keys move the selected object the Grid Snap Interval as set in the Grid Control 
dialog. The left and right arrows move the entities in the + and – X directions. The Up and Down arrows move the 
entities in + and – Y directions. The PgUp and PgDn keys move the entities in the + and – Z directions. If the WCS box 
is checked in the SCC, then all movement is based on the current WCS. If the WCS box is not checked, then the 
movement is based on the global coordinates. 
 
Moving the WCS (SHIFT + Translation shortcut keys) 
If the SHIFT key is held down while pressing any of the Moving shortcut keys, the WCS is changed instead of the 
selected entities. 
 
Rotating the WCS ( WCS Rotation shortcut keys) 
The keys and rotation increment are specified in the WCS Dynamic Rotation Control dialog. Rotations are always 
based on the SCC position and WCS axes. The rotation keys can be specified by the user. 
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Window Display (View menu) 

Window Display Control 

For your convenience, AMPSolid provides several window display controls that allow convenient examination of the 
current model and status. 

Camera Controls (View menu) 

 
AMPSolid’s model space is a three-dimensional volume.  The view volume is defined as the space that is visible from 
the window’s view port.  AMPSolid’s view camera control enables the user to control the size of the view volume in this 
viewport. 

 
View volume size is determined by the Viewport Width/Height/Scale edit box.   The size specified is in the same 
dimensions as your model.  
The viewport center is the view target position. This is usually the average geometric center of the model.  Be default, 
the viewport center is set to the global origin (0, 0, 0). 
The perspective mode allows the view to be examined following the depth ratio, in a perspective manner. 
The user can set these parameters manually. In most cases, these values are set automatically by the Zoom-All 
function.   If the current settings set the view volume to an empty space, the Zoom-All icon or menu command can be 
used to quickly reset the parameters. 
Re-Display (View menu) 
This option is rarely used in the current version. In previous versions of AMPSolid this option was used to refresh the 
screen when the Windows system palette changed using 256 screen colors. 

Zoom View (View>Zoom menu) 

 
Several view zooming functions are provided for your convenience.  
The Zoom All function automatically changes the window size to display the largest possible view of your entire 
model.   
The Zoom In and Zoom Out menus and icons have a roughly 50% zoom-in and zoom-out ratio. 
The Zoom Window lets you draw a rubber-band box to enclose the desired rectangular portion of your model and 
resize the view window to enclose that selection. 

Preset Camera Views (View>Camera menu) 

 
Several preset camera views are available.  The Isometric View is a popular camera view angle.  Other preset camera 
view positions are: Left yZ, Right Zy,Front Zx, Back xZ, Bottom xY and Top Yx.  
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The naming convention (left, right etc.) is based on the Isometric View. The coordinate convention is to use a capital 
letter for the axis that points up. If the horizontal axis points to the left, it is before the capital letter. If the horizontal axis 
points to the right it is after the capital letter. So the standard XY axis is described as Yx to signify that Y points up and 
X is horizontal and points to the right. 

Dynamic View (View>Camera menu) 

Dynamic views dynamically change the screen as the left mouse button is held down. 

 Dynamic Pan Icon 
The dynamic pan control allows the screen to be dynamically moved within the window by dragging with the left 
mouse button. 

 Dynamic Rotate Icon 
The dynamic rotation control follows mouse movement and rotates the camera left, right, up or down around the object 
being examined.    

 Dynamic Zoom Icon 
The dynamic zoom control allows the user to zoom in (or out) by dragging the left mouse button up (or down). 
The Dynamic View commands are toggle commands and can be use to change the view during the construction of 
geometric objects without aborting the objects. Just click on the toolbar icon when it is on to turn it off and return to the 
previous non-toggle (construction or selection) command. 
The right mouse button can be pressed to toggle off the Dynamic View commands and restore the previous non-toggle 
command. 

Cutting Planes (View>Cutting Plane menu) 

 Cutting Plane Toolbar 
The views in the Cutting Plane Toolbar correspond to the initial cutting planes as seen from the Isometric view. 
 
Cutting planes can be created in the YZ, XZ or XY planes. After they are constructed, they can be moved and rotated.  

 
To move the cutting plane drag straight two-arrowed icon on the white cutting plane axis that is perpendicular to the 
cutting plane.  
To rotate the cutting plane, start dragging on one of the curved rotation icons around one of the white cutting plane 
axes in the cutting plane. Dragging after starting on the curved icon around one axis allows the cutting plane to rotate 
about that axis. 
Viewing and selecting planes within a solid 
The cutting plane as well as the View>Transparency option are useful in viewing the insides of solids. The cutting 
plane allows inner faces of a solid to be selected with the Face Selection tool. 

Cutting Plane Visibility Options (View>Cutting Plane menu) 

The following visibility options are available for the cutting plane: 
Show Plane: If checked, the partially transparent, gray cutting plane is displayed. (Typically on) 
Show Cutting lines: If checked, the white cutting lines are displayed at the intersection of the solids with the cutting 
plane. (Typically on) 
Cap Solid Insides: If checked, then the region of the cutting plane inside a solid is displayed as a black cap so that 
the insides of the solid are not seen. (Typically off) 
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Color Options (View menu) 

The color option menu enables you to change the default color settings used in AMPSolid. If you modify the current 
color settings, your new settings are automatically saved for reuse in subsequent AMPSolid sessions.  

  
Selecting the Color menu item displays a color selection dialog box from which you can easily select an existing color 
or create you own by mixing hues of red, green, and blue. 
 
 
Available color controls are: 
 
Background color: changes the window’s background color. 
Highlight color: changes the color used to highlight selected entities. 
Default color: changes the default color assigned to newly created entities. 

Coordinate Axis Display Control 

(View>Display Axis) 

Turning this option on or off controls whether the global axes is displayed. 
 

Transparency View Option 

This option is used to trigger the transparent display so the user can see the model internal entities.  It is useful when 
the pick depth is greater than one for the internal object selection (although the inside side of surfaces does not always 
show selection). See the pick depth control section of the SCC window controls for more information. 
 

Other View Options 

Rendering Modes (View menu) 

 
The Render modes are available for curious users and users that want to experiment with shading options before 
copying the screen to the clipboard. 
Flat Shaded: Flat shading shows the tessellation used to render the curved surfaces. Each flat polygon is shaded 
based on the normal. 
Gourand Shaded: This method of smooth shading determines the shading at each vertex using a normal at the 
vertex. It then uses bilinear interpolation to shade each flat polygon. This option turns off edge and vertex display. 
Phong Shaded: This method of smooth shading determines the normal at each vertex and then interpolates the 
normal over the surface. The intensity at each point is determined based on the normal at each point. Phong shading 
is more accurate in depicting specular shading than Gourand Shading. This option turns off edge and vertex display. 
Lights: This changes the lighting. 
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Options and Configurations 

Status and Cursor Control (SCC) 

(Option>SCC Box) 

The status and cursor control window (SCC) is an additional floating top window that simplifies position, distance and 
angle measurement, and also controls cursor snapping. This window is one of the more important control windows in 
AMPSolid, providing both functional control and useful feedback.  

 
The SCC window provides keyboard entry of positions, controls whether the global coordinate system or the working 
coordinate systems is used for operations and point entry, allows the pick depth to be changed (Pick depth controls 
which entity is selected when the cursor is above several entities) and displays the current total number of items and 
number of FE items selected. 
 

Entering coordinates using the keyboard 

Points can be entered in AMPSolid using the mouse or the SCC Dialog. To use the SCC Dialog, enter the X, Y and Z 
values of the position and click on the Enter Pos button.  
The Tab and Enter keys can be used to enter multiple points by keyboard without having to take your hands off the 
keyboard. Pressing the Enter key when the Enter Pos button has the focus (dotted rectangle around the text), enters 
the point in AMPSolid. After the Enter Pos button is used (clicked by the mouse or using the Enter key), the position X 
button field is selected and the user can enter a new value. Using the Tab key takes you to the next field. Using the 
Tab key after the Position Z value, take you to the Enter Pos button. This means that the coordinates for a line 
between (1, 1, 0) and (2, 2, 4) can be entered completely from the keyboard. To do this select Create>Line and then 
double click on X in the SCC and use: 
1 Tab 1 Tab 0 Tab Enter 
2 Tab 2 Tab 4 Tab Enter 
The [Enter Vec+Pos] button 

To enter a position a fixed distance from the current position being displayed, enter the distance change in the X, Y 
and Z fields for the Vector (2nd line). Then, click the Enter Vec+P button. This adds the Vector values to the Position 
values and enters that as the new position. 
 
Reset 
The Reset button is a shortcut to zero out the position values. 
 

The WCS (Working Coordinate System) checkbox 

If WCS is checked, a wcs appears in front of the X to indicate WCS coordinates are being used. A (WCS) appears 
after Vector to emphasize that the Vector value is in WCS coordinates. Also, the current SCC position and vector are 
converted into the equivalent WCS position. 
All commands that use the SCC position or vector have been modified to take into account the WCS checkbox. Also, 
the shortcut keys (Arrows + PgUp/PgDn) use the WCS checkbox. These shortcut keys move either the WCS (if shift is 
down) or the selected geometric objects in the appropriate direction. The distance moved is the same as the 
Edit>Grid Snap Control …  dialog values. 
Rotations are always performed based on WCS coordinates. If WCS is selected the center of rotation (SCC position) 
is interpreted as in WCS coordinates. 
 

Updating the Position and Vector values from the model geometry 

The Position value is updated whenever a snap point is used in construction. It can also be updated to any snapable 
position by holding down CTRL key (for snapping) and SHIFT key (to record moves in the SCC) and moving the 
mouse.  

The SCC Vector value is updated when the Edit>Measure>Dist/Vec 2Pts command is used.  



AMPSolid Reference Manuall 

18 

 

The CTRL Snap Pulldown 

When the CTRL key is held down, a + shaped snap cursor in the WCS XY plane appears on the screen at the current 
snap location. The following snap options are available: 

Vertex: Snap to the closes vertex 

Grid: Snap to the WCS grid in the XY plane. The spacing for the grid is set in the Edit>Grid Snap Control dialog. 

Mid Edge: Snap to the middle of a curve or edge. The cursor has to be close enough to the middle of an edge for the 
+ snap cursor to be visible and snapping to occur. 

Face Center: Snap to the center of the closest face. The cursor has to be close enough to the middle of an edge for 
the + snap cursor to be visible and snapping to occur. 

Body Center: Snap to the center of body. The cursor has to be over the body for snapping to occur. It is best to use 
the Transparency View mode (View>Transparency View) to be able to view the snap cursor within the body. 

 

CTRL Right Button SNAP to cursor shortcut 

In snap mode (with CTRL down), moving the mouse with the right button down overrides the current snap mode with 
Vertex snap mode. Letting the right mouse button UP with CTRL down enters the current vertex position as if it were 
snapped. If you don’t want to enter a point after pressing the right button down, let the CTRL key UP before letting the 
right mouse button up. With the CTRL key UP, no point is entered when the right button goes up. 
Quick vertex snap is disabled for Create>Curve>Polyline and Create>Curve>Spline because the right button has 
special meaning. Set CTRL Snap Pulldown to Vertex and use the CTRL key to snap to vertices when using these 
commands. 
Holding down both the CTRL (snap) and the SHIFT (copy to SCC position when mouse moved) allows you to copy the 
vertex positions to the SCC. Remember to let the CTRL key up before the right mouse button if you don’t want to enter 
a point into your model. 

Pick Depth Filter 

The SCC window also provides an optional pick depth control to simplify the selection of objects hidden beneath the 
visible surface of your models. When this option is selected, picking an entity will only select the nth entity behind the 
entity you selected. If the selected entity does not have enough entities behind or below it, AMPSolid will select the 
last object. 
 

Picked = and FE = 

The number if geometric entities currently selected is shown after Picked =. The number of FlexMesh items affected 
by the last FlexMesh operation is shown after FE =. 

 

Toolbar Controls 

The Toolbars menu activates or deactivates the "dockable" toolbar control.  "Dockable" toolbars can be dragged by 
their frame and can be attached to any of the four sides of the main windows. They can also be used as "floating" 
toolbars (unassociated with any window border) by dragging the toolbar windows into any position in the screen. You 
can use the Window menu’s Save Windows Position option to save the current state of all windows in AMPSolid. 
Moving the mouse over any AMPSolid toolbar icon and keeping it there for a short period will trigger popping up a "tool 
tip" message. This tool tip feature is helpful to identify the function of any toolbar icon. 
AMPSolid provides several toolbars consisting of related operations that are grouped together to reduce mouse 
movement.  The icons for each of these toolbar operations have been carefully designed to reflect the functions they 
represent. 
You can press F1 at any time to view the help message for each individual toolbar function. A "What is this" toolbar 
icon is also available. While this icon is active, you can place the "?" cursor on any menu and icon and right-click to get 
detailed help. 
Toolbars available are: 
Status Bar: 

 
General Toolbar: 

 
View Control Bar: 
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Selection Control Bar: 

 
Display Control Bar: 

 
WCS Control Bar: 

 
Measure Bar: 

 
FlexMesh Control Bar: 

 
 

Dialog Message Window (Option menu) 

The Dialog Message Window is typically only used for user controlled FlexMesh construction. This message box will 
pop up automatically when there is an important message. It is mostly used to report internal meshing and solid 
modeling problems. Messages can be copied from this window to standard Windows applications using standard 
Windows operations.  

Clear All Tools (Options menu) 

In AMPSolid, user input is internally associated with various mapping functions for filtering, coordinate mapping, and 
snapping. Selecting the Clear All Tools option allows you to remove all of these internal mapping functions.  You do 
not usually have to select this option, as these functions are normally created and discarded automatically by 
AMPSolid. However, after using a large number of different filter and selection functions, it may be useful to select this 
option to ensure that no filter function is accidentally enabled. 
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Working Coordinate System 

Working Coordinate System (WCS)  

(Edit>Working Coord Sys menu) 

In 3D geometric work, it is always important to know the position of the mouse entry plane. AMPSolid uses the XY 
(z=0) plane of the Working Coordinate System (WCS) as the mouse entry plane. The WCS is initially set to the Global 
XYZ axis.  
To make the initial WCS (global at the origin) visible, Click the WCS Dialog toolbar button then click the Set Default 
button. 
Most WCS modifications are performed using the WCS Toolbar. This toolbar is usually along the left side. 

 
The commands are (from right to left or top to bottom if the toolbar is on the left side) 
WCS to a Pt: Moves the WCS to the next entered point. Does not change axis direction 
WCS by 3 Pts: Use 3 points to enter a new WCS. The first point is the origin, followed by a point in the X axis direction 
and a point defining the Up Y side of the X axis and the XY plane. 
WCS by Face: Select this option then click on a face to create a WCS axis in the plane of that face. 
WCS Align Global: Select this option to align the WCS axis with the global coordinate system. 
WCS Translate: Translate the WCS based on the current SCC vector. 
WCS Rotate: Rotate the WCS based on the current SCC Rotation angles. 
WCS Dialog: Access the WCS dialog to view WCS parameters or select a WCS previously used in this session. 
 
WCS toolbar options are toggle commands 
Toggle controls can be used during entity construction without aborting the construction. See Toggle Commands for 
more details. 

Create/Move WCS to a Point 

 or (Edit>Working Coordinate System menu) 
This option moves a WCS axis to the specified point without changing the orientation from the current WCS. 
To use this option: 
a. Select the option from the Edit menu’s Working Coord Sys submenu. 
b. Enter a point using the mouse or SCC. 
Note that if you want the WCS to be exactly at a vertex, you should turn on the SCC dialog’s vertex snapping option 
and hold down the control key while picking that point. This causes the cursor to snap to the selected vertex. You can 
also hold down CTRL and use the right mouse button to snap to a vertex, see Keyboard Shortcuts. 
WCS toolbar options are toggle commands 
Toggle controls can be used during entity construction without aborting the construction. If you don’t want to construct 
a WCS, just click on the toolbar icon to toggle off the command. 

Create WCS from 3 Pts 

 or (Edit>Working Coordinate System menu) 
This option creates a WCS from three selected vertices. 
To use this option: 
a. Select the option from the Edit menu’s Working Coord Sys submenu. 
b. Select the origin by clicking the cursor on a point. 
c. Select the vertex to define the x-axis. 
d. Select vertex to define the plane and the y-axis side. 
Note that if you want the WCS to be exactly at a point, you should turn on the SCC dialog’s vertex snapping option 
and hold down the control key while picking that point. This causes the cursor to snap to the selected point. You can 
also hold down CTRL and use the right mouse button to snap to a vertex, see Keyboard Shortcuts. 
WCS toolbar options are toggle commands 
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Toggle controls can be used during entity construction without aborting the construction. If you don’t want to construct 
a WCS, just click on the toolbar icon to toggle off the command. 
 

Create WCS from Planar Face 

 or (Edit>Working Coordinate System menu) 

This is for use on planar faces only. 
To use this option: 
a. Select this option from the Edit menu’s Working Coord Sys submenu. 
b. Click on the face on which to create the WCS. 
By default, AMPSolid will select a vertex at which to place the origin of the new WCS.  If there is no vertex on the 
plane, the origin will be placed at the point where the mouse was clicked. You can also hold down CTRL and use the 
right mouse button to snap to a vertex, see Keyboard Shortcuts. 
WCS toolbar options are toggle commands 
Toggle controls can be used during entity construction without aborting the construction. If you don’t want to construct 
a WCS, just click on the toolbar icon to toggle off the command. 
 

Create WCS Pt. on face 

This creates a WCS point on a face, but enables you to specify the origin. 
To use this option: 
a. Select this option from the Edit menu’s Working Coord Sys submenu. 
b. Click on the point that will be the WCS origin. 
c. Click on the plane where the WCS XY plane will be located. 
Note that if you want the WCS to be exactly at a point, you should turn on the SCC dialog’s vertex snapping option 
and hold down the control key while picking that point. This causes the cursor to snap to the selected point. You can 
also hold down CTRL and use the right mouse button to snap to a vertex, see Keyboard Shortcuts. 
 

 

Align WCS Axis to Global 

 or (Edit>Working Coordinate System menu) 
 
This option removes all previous rotations imposed on the WCS and resets the axis to the global directions. 
To use this option: 
a. Select this option from the Edit menu’s Working Coord Sys submenu. 

Apply Translate to WCS 

 or (Edit>Working Coordinate System menu) 
This operation uses a vector that you define in the SCC to move the WCS axis. 
To use this option: 
a. Define a vector in the SCC. 
b. Select the option. 
If the WCS checkbox on the SCC dialog is checked, the vector is interpreted in the current WCS coordinates. 

Apply Rotate to WCS axis 

 or (Edit>Working Coordinate System menu) 
 
This applies a defined rotation vector in the SCC to rotate the WCS axis. The rotation operation is applied in the 
sequence of X rotation, Y rotation, and Z rotation. Rotations are about the current WCS axes. 
Operation 
a. Define a rotation vector on the SCC, this could be from a previous angle measurement or a manual input. 
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b. Select this option from the Edit menu’s Working Coord Sys submenu. 

Dynamic Rotation Control 

(Edit>Working Coordinate System menu) 
Selecting this option displays a dialog box where you can set the keys used to rotate the WCS in the increment of 
rotation per selection. 
Assigning rotation operations to new keys adds those bindings to the keys that will trigger WCS rotation - the default 
values are always available. 

 
 

Keyboard control of Selected Entities and the WCS-axis 

The following keys control the movement of selected or highlighted objects. 

• The up, down, left and right arrow keys control the movement of selected objects in plane by an increment 
specified in the grid control. 

• The Page Up and Page Down keys control the movement of selected objects along the Z axis. 

• The +/- keys can also be used to control the movement of selected objects along the Z axis 
 
Holding down the Shift key with these keys will change the WCS-axis itself.  
 

WCS (Working Coordinate System) Dialog 

 toolbar icon or (Edit>Working Coord Sys>WCS Dialog …) 
The WCS Dialog is used to display the origin and axis coordinates of the current WCS, allow access to previously 
WCS defined during this session and control WCS/SCC information dialogs that are displayed before commands that 
use WCS/SCC information. 
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Previous WCS button 
The Previous WCS button changes the current WCS to the previously used WCS. It can be used like an undo button if 
you accidentally apply the wrong transformation to the current WCS. It can also be used to view the parameters and 
location of any WCS previously used in the current AMPSolid session. 
 
Next WCS button 
The Next WCS button is like a redo command after using the Previous WCS button.  
 
Default WCS button 
The Default WCS button generates a default WCS with the axes aligned with the global axes and the origin at (0,0,0). 
 
Show WCS/SCC info dialogs: 
This pull-down is used to change how frequently WCS/SCC info dialogs are displayed. The followed options are 
possible: 

• Always (new users) – Always display the WCS and corresponding SCC values to remind new users where 
which values correspond to the current command. 

• Sometimes (Frequent user) – Only display the WCS/SCC info dialogs before infrequently used commands 
that take special parameters from the SCC (like the Solid Modification>Blend command). 

• Never (Advanced user) – Never display the WCS/SCC info dialogs before commands. 
 

Cancel or [x] 
If the Cancel button or [x] (close dialog button) is used, all changes are discarded and the WCS that was active when 
the dialog was displayed is reactivated. 
 
OK 
If the OK button is used, any changes to the Show WCS/SCC info option are recorded and the currently displayed 
WCS becomes the active WCS. 
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Geometric Entities 

Geometric Entities 

A geometric model is composed of a body, one or more faces, multiple edges, and multiple vertexes, in order of 
descending hierarchy. AMPSolid provides tools to create any higher-level entity through the appropriate combination 
of hierarchically lower entities. AMPSolid provides an entity filter to simplify and ensure the selection of desired types 
of entities. 
The geometric modeling tools provided in AMPSolid are designed to help you create standard engineering shapes as 
well as six faced general blocks. These primitives and blocks are then used in the constructive geometry generation of 
the final body. 
The following toolbar is the Selection Control Bar: 

 
 

The Body Selection Tool 
The body selection tool should be used for selecting any solids or isolated surfaces that are going to be transformed 
(translated or rotated). The body selection tool will also select wire-bodies so they can be transformed. Curves that are 
not wire-bodies must be selected with the edge tool to be transformed. The simple rule is to select geometric objects 
with the body tool unless you only need a component of that object. If the object tool does not select a curve, try 
selecting the curve with the edge selector. 
 
In version 3.00 and above of AMPSolids, all surfaces are created as face-bodies with two sides and should be 
selected and manipulated with the body selection tool. Isolated faces (both one sided and two sided) loaded from older 
AMPSolid files can be converted to surfaces (Sheet-bodies) using the Modify>Surface Modification menu. 
 
The Face Selection Tool 
The face selection tool is used to select just one face of a solid. It is used for the Modify>Solid Modifications>Sweep 
a face command so solid can be modified by transforming a single face. 
 
The Edge Selection Tool 
The edge selection tool must be used to select curves that are not wire-bodies for transformations. In general, if an 
object can be selected by the body selection tool, the body selection tool should be used to select the body for 
transformation. If the body selection tool doesn’t select a curve, use the edge selection tool. 
The Edge selection tool is also used to select the edges of solids for the Fillet operation (Modify>Solid 
Modifications>Blend Edges). 

 

Entity Display Control (View>Display Control menu) 

A dedicated toolbar is available to display entities in various ways:  

 
The icons in this toolbar provide the following features: 
Display Face Shaded: displays faces in a shaded color with light shading. 
Display Edges: displays edges using color. 
Display Vertices: displays vertices using color. 
Transparent View: Makes the faces transparent allowing the user to see inside the solids. 

Selection Tools (Edit>Select menu) 

The following toolbar is the selection control bar: 

 
The icons on the toolbar restrict selections to bodies, faces, edges, vertexes, and unselect All (unselect all 
geometric entities). You can select multiple geometric entities by holding down the Shift key while selecting each 
entity. To remove the current selection list, click the None icon (the rightmost icon of the selection filter without any 
highlight). You can also do a region selection by clicking the left mouse button without letting go, then move the mouse 
to form a region. All items inside or partially inside the region will be selected based on the current selection tool. 
A Pick Depth Filter may be activated by right clicking (in selection mode) or by changing the picking depth edit box in 
the SCC box.  This allows the selection of objects that can not be seen when shading is on because they are below or 
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behind a shaded surface.  Additional filters are available under Edit>Selection Filter. It is usually easier to use the 
Cutting Planes to select inner surfaces of solids than the Pick Depth Filter because you can see the surface you are 
selecting. 
The selection filters are implemented to make it easy for you to select portions of the geometry of your model and are 
bound to the mouse cursor when active.  Once activated, selection filters are active until some other command 
associated with the mouse cursor (such as a view rotation tool) is selected. 
Selection in AMPSolid follows the Windows' standard for multiple selections.  Holding the Shift-key while clicking the 
left mouse button will add the item to the selection list, while holding the Control-key with the left mouse button clicking 
will toggle the selected item. 
When the option Enable Pick Dragging is activated, it allows free hand translation of the selected top entity, i.e. an 
entity that is selected does not belong to any upper entity. This is usually use for some quick body translation, but 
unless snapping control is activated, it will not have the precise engineering movement needed. 

Pick Selection Filter (Edit menu) 

During the graphic selection process, you can use the following dialog to activate specific selection filters. These make 
it easier to select the exact entities you want: 

 
Top Level Entity Only: a top level entity is a entity whose parent is itself. Normally, when you pick a body entity, a 
body’s top level entity is the body itself.  A face, however, is usually associated with a body. If you use the "top level 
entity only" filter, attempting to select a face will yield nothing if the face is not a sheetbody. Similarly, when working 
with wire frame bodies, an edge usually has a face as its parent. The face (surface) then has its own parent(s).  When 
an edge is a wire frame body, it is a top level entity because its parent is the edge itself. 
FlexMesh Entity Only: when there are various points on the screen, it is sometimes difficulty to know which points are 
geometry points and which are FlexMesh cell points. By using this filter, you can effectively select only FlexMesh-
related cells or cell points. 
Pick Color Filter this filter will allow only objects with the designated color being selected.  To set the color filter, click 
the Set Color button. 
High Light Face's Edges When Selected when a face is selected, it turns it's color into the highlight color to inform 
the user of the active selection. Sometimes, when a face is hidden and is selected using depth selection technique, it 
is more convenient to also high light the face's edge to identify the active selection.  Using this function with the 
surface shading off is usually needed when there are lots hidden faces selection tasks.  
Pick Depth Filter this filter will allow only objects with the designated view depth count being selected.  By default, the 
depth count is one, the visible surface from the view window. This setting is needed to select the hidden bodies or 
faces when they are behind the top surface. 

Entity Measurement (Edit>Measure menu) 

Measure commands are available on the Measure Toolbar 

AMPSolid provides three basic entity measurement tools:. 
2-Point Distance: after picking two points, the distance is calculated and displayed in the SCC dialog’s vector/length 
field. Selecting Translate (the second icon from the right or bottom of the Measure Toolbar) after measure will move 
the selected top-level entities the distance that was measured. 
3-Point Angle: after picking three points, the angle from points 1 and 2 line to points 1 and 3 line is calculated and 
displayed in the SCC dialog’s X rotation angle 
Curve Length: After picking any curve, its length is calculated and displayed in the length field. The length of a vector 
formed from the curve’s beginning to end points is also calculated and displayed in the vector component fields. 
Closed curves display a non-zero length but have zero for the vector components because the starting and ending 
points are the same. 
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The measure toolbar also contains icons for Translation and Rotation 
Translation: Translate the selected top-level entities the vector distance specified in the SCC Vector. Using this 
immediately after 2-Point Distance measurements allows bodies to be translated the distance that was just measured. 
Rotation: Rotates the selected top-level entities based on the WCS axis and WCS position. See Rotate for more 
details. 

 

Geometry Tolerance Control (Options menu) 

This option is for advanced solid modeling tolerance control. It is suggested that the user use the default setting 
without changing them.  However, when a solid model is imported from other CAD system, the model could have very 
large tolerance due to the CAD software’s design.  In such case, the default geometry tolerance could be too strict and 
will cause geometric operation to fail.  In such case, the relaxing of the geometry tolerance is necessary.  
 

 
RESABS is named for resolution absolute. It is the smallest meaningful quantity representable in solid modeling. This 
can be interpreted as the distance below which the solid kernel considers two points to be coincident. If two points, A 
and B, are separated by less than resabs, they are considered to be the same point.  
resabs also represents the smallest feature being modeled, since it is the smallest distance between two points. The 
default value is 10-6. The default value was chosen assuming that at least an order of magnitude guard band around 
resabs is required 
RESFIT is named for resolution fit. This is used as a guide to the fitting algorithms for the fit tolerance of an 
approximate curve or surface. The default value is 10-3. Polynomial approximations are computed for some curves and 
surfaces in modeling. The approximations are stored in the model together with their corresponding curve or surface 
definitions. Some fitting algorithms are adaptive, and therefore may produce tighter fits than resfit in certain 
circumstances; for example, in regions of high curvature.  
RESNOR is named for resolution normalized. This is the ratio of the smallest meaningful quantity representable in the 
solid modeling kernel (resabs) to the largest. This reflects the precision to which numerical values are calculated and 
stored. The default value is 10-10.  
RESMCH is the largest number considered to be zero by the computer. The default value is 10-11.  This value can vary 
from platform to platform and should never be modified--it is for internal use only. 
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Entity Creation 

Geometry Creation (Create Menu) 

The geometry creation menus help you create basic portions of the geometry of your model. Once activated, these 
tools are active until some other command associated with the mouse cursor (such as a view rotation tool or selection 
filter) is selected. 
Separation bars separate the Create Menu into five sections. The first section contains Vertex creation options, the 
second section contains edge (line and curve) creation options, the third section contains surface creation options and 
the fourth section contains solid creation operations. The Abort Geometry Tool option (or any Selection Toolbar item) 
can be used to abort the current creation of an geometric object. 

Abort Geometry Tool (Create menu) 

Most of the geometry creation processes require using the mouse left/right button clicking and movement.  Once a 
geometry entity is created, it then start the creation process again by waiting for another cycle of mouse actions.  
Sometimes, it is desirable to abort this process, and this option is designed specifically to do so.  Selecting one of the 
Selection options or another construction method will also abort the current construction operation. 
The Toggle Commands (Dynamic Rotate, Zoom, Pan etc.) do not abort the construction command. After using these 
to change the view, the user can click on the Toggle Command again to turn it off and continue with the construction.  

Vertex Creation 

Vertex Creation 

Vertices are created either by positioning the cursor using the grid smart snap option or by defining their position in the 
SCC dialog. 

Create vertex by smart snap 

To use this option: 
a. Select Create>Vertex>Create by point 
b. Activate the appropriate smart snap type in the SCC dialog. Note that the snapping can be to the grid, point, face 

center, etc. 
c. While holding the control key, click a closest geometry point to define vertex. 

Note that this tool will then repeat itself in step C again as long as this menu is active.  Also, if you do not use the 
snapping, the left button of the mouse click will just project a point onto the current WCS working plane. 

Create Vertex by point (Create>Vertex menu) 

To use this option: 
a. Enter the vertex coordinates into the SCC dialog. 
b. Select this option. 
c. Click the left mouse button to create a vertex at the specified point. 
Note that this tool will then repeat itself from step C again as long as this menu is active. 

Project Vertex to Edge (Create>Vertex menu) 

To use this option: 
a. Select this option. 
b. Select the vertex/point to be projected using the vertex selector. 
c. Select the edge to project to.  A new vertex point will be created on the edge that is closest to the original point. 
Note that this tool will then repeat itself from step b again as long as this menu is active. 

Project Vertex to Face (Create>Vertex menu) 

To use this option: 
a. Select this option. 
b. Select the vertex/point to be projected using the vertex selector. 
c. Select the face to project to.  A new vertex point will be created on the face that is closest to the original point. 
Note that this tool will then repeat itself from step b again as long as this menu is active. 

Edge Or Curve Creation 

Edge Or Curve Creation (Create menu) 

A curve may be generated by using the following options: 
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Line – create a line 
Rectangle – create 4 lines bounding a rectangle 
Arc – create a circular arc 
Curve>Circle – create a circle 
Curve>Ellipse – create a closed ellipse 
Curve>Spline – create an interpolating spline 
Curve>Polyline – create connected lines 
Curve>Project curve to face - create a curve on a face that is the projection of another curve. 

Line creation (Create menu) 

This option defines two end points on the WCS working plane (plane formed by the WCS 1 and 2 axes, hereafter 
referred to simply as the WCS plane). 
To use this option: 
a. Select the option 
b. Select the starting position by clicking the left mouse button. 
c. Select the second end point by clicking the left mouse button. 
d. Repeat steps b and c to create additional lines. 
 
If you want to select a pre-existing point when creating a line, use the CTRL Right Button Up keyboard shortcut. Hold 
down the CTRL key and, while holding the right mouse button down, move the mouse so the snap cursor is at the 
correct vertex. Then, let the right button up to enter the point. 

Rectangle creation (Create menu) 

This option creates a rectangle by diagonally dragging a rubber-band outline. The rectangle is created as four straight 
lines. 
To use this option: 

a. Select the option. 
b. Select the lower left corner of the rectangle by clicking the left mouse button. 
c. Move the rubber-band diagonal to the upper right corner of the rectangle, then click the left mouse button. 
d. Repeat steps b and c to create additional rectangles. 
e. To terminate the operation, click any selection icon or "Create/abort Geometry tool". 

Circle creation by defining radius (Create>Curve>Circle menu) 

This option creates a circle by defining the center point and dragging the rubber-band to define a radius. 
To use this option: 
a. Select the option. 
b. Select the Center point by clicking the left mouse button. 
c. Move the mouse cursor to the point to define the circle’s radius on the WCS plane, then click the left mouse 

button. 
d. Repeat steps b and c to create additional circles. 
e. To terminate the operation, click any selection icon or "Create/Abort Geometry tool". 

Circle creation by defining a diagonal (Create>Curve>Circle menu) 

This option creates a circle by defining the end points of a diagonal. The circle is displayed as the cursor is moved to 
select the second point. 
To use this option: 
a. Select the option. 
b. Select the first point by clicking the left mouse button. 
c. Select the second by left mouse clicking to define the diameter of the circle. 
d. Repeat steps b and c to create additional circles. 
e. To terminate the operation, click any selection icon or "Create/Abort Geometry tool". 

Arc through 3 points Ends first (Create>Arc menu) 
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This option creates an arc from 3 points. The end points are entered first and the shape of the arc can be previewed 
while moving the mouse before entering the 3rd point. Vertex snapping can be used to create arcs in the plane of any 
three vertices. 
To use this option: 
a. Select the option. 
b. Select an end point by clicking the left mouse button or using a button on the SCC. 
c. Select the other end point by clicking the left mouse button or using a button on the SCC. 
d. Select a point on the arc to define the arc. 
e. Repeat steps b and e to create additional circles. 
f. To terminate the operation, click any selection icon or "Create/Abort Geometry tool". 
 
 

Circular Arc Creation from three points (Create>Arc>Arc thru 3 pts) 

This option creates an arc by defining the first, middle, and end points of the arc. 
To use this option: 
a. Select the option. 
b. Select the first point of the arc by clicking the left mouse button. 
c. Select the midpoint of the arc by clicking the left mouse button. 
d. Select the end point of the arc by clicking the left mouse button . 
e. Repeat step b to d to create more arcs. 
f. To terminate the operation, click any selection icon or "Create/Abort Geometry tool". 

Circular Arc Creation from center and two positions or angle  

(Create>Arc>Arc(center,radius, Pos/Angle)) 

This option creates an arc by defining the first, middle, and end points of the arc. 
To use this option: 
a. Select the option. 
b. Select the center of the circle by clicking the left mouse button. 
c. Select the first/beginning point of the arc (this also defines the radius) by clicking the left mouse button. 
d. Select the second point of the arc, or enter the desired angle in the SCC menu RotX (rotation angle X field) and 

click the mouse left button to form the arc. 
e. Repeat step b to d to create more arcs. 
f. To terminate the operation, click any selection icon or "Create/Abort Geometry tool". 
 

Ellipse Creation (Create>Curves menu) 

This option creates ellipses by defining their center and two axes. 
To use this option: 
a. Select the option. 
b. Select the point to be the center of the ellipse by clicking the left mouse button . 
c. Select the position of the major axis by clicking the left mouse button. 
d. Select the position of the minor axis by clicking the left mouse button. 
e. Repeat step b to d to create more Ellipses. 
f. To terminate the operation, click any selection icon or "Create/Abort Geometry tool". 
 

Spline Creation (Create>Curves menu) 

This option creates a spline by defining a series of points. Clicking the right mouse button indicates the end of the 
spline creation operation. The last point clicked is used as the last point of the spline - the right click does not define a 
point on the spline. 
To use this option: 
a. Select the option. 



AMPSolid Reference Manuall 

32 

b. Select the first point of the spline by clicking the left mouse button. 
c. Select as many points as needed to define the spline by clicking the left mouse button. 
d. Right click to end the definition of the spline. 
e. Repeat step b to d to create more splines. 
f. To terminate the operation, click any selection icon or "Create/Abort Geometry tool". 
The CTRL Right Button Up shortcut is disabled during spline construction. To snap to vertices, set the SCC CTRL 
Snap pull-down to vertex and use CTRL and the left button. 

Polyline Creation (Create Curve menu) 

This option defines a polyline by defining a sequential number of straight lines. 
To use this option: 
a. Select the option. 
b. Select a starting point by clicking the left mouse button. 
c. Select a number of points to define a sequence of straight lines by clicking the left mouse button. 
d. Right click to end the definition of the polyline. Note that to back up a point previously created, press the right 

mouse button while pressing the shift-key. To close the polyline back to its beginning point to form a closed 
polygon, click the right mouse button while pressing the control-key. 

e. Repeat step b to d to create more polylines. 
f. To terminate the operation, click any selection icon or "Create/Abort Geometry tool". 
The CTRL Right Button Up shortcut is disabled during spline construction. To snap to vertices, set the SCC CTRL 
Snap pull-down to vertex and use CTRL and the left button. 

Project curve to a face (Create>Curve menu) 

To use this option: 
a. Select this option. 
b. Select the curve to be projected 
c. Select the face to project to.  A new curve will be created on the face based on the closest projection distance.  If 

the projection is successful, a dialog box will show up to allow etching and cutting the face from the projected 
curve.  If the projected curve is a closed loop, it will essentially split the original into two faces (one inside the 
loop, and one outside).  This is useful when an edge/curve feature is desired on a face. 

Note that this tool will then repeat itself from step b again as long as this menu is active. 
 

Surface 

Surface Creation Methods (Create menu) 

Surfaces can be constructed from curves (lines, arcs, splines), edges or wire-bodies (curves glued together to make a 
body that represents a single curve). The following construction methods are available: 
 
Cover closed curves: A connected sequence of closed curves is selected in order (the next selected curve must 
share a vertex with the last curve selected). A surface is created in the region bounded by the curves. The curves do 
not need to be in the same plane. 
Skin through curves: By selecting disconnected curves or edges, an interpolating surface is generated that passes 
through each curve. This is best suited for creating a ruled surface between two curves. When skinning two curves, 
the two new edges (between the curves) are lines. 
Two Direction Skin>Skinning with edge: This is an extension of the skinning method. This is the recommended 
operation when multiple skinning curves are used and all 4 surface edges are specified. The curves in the skinning 
direction must end on the two edge curves. 
Two Direction Skin>first half U method: This is a generalization of the Two Direction Skin>Skinning with edge. It 
allows multiple curves to be skinned in both the U and V direction. It is fairly difficult to construct as the curves must all 
begin and end on one of the sets of edge curves that form the surface edge. Also, where the curves cross in the 
middle of the surface, they must cross (or intersect) within the model tolerance. 
Surface by Sweeping: These are surfaces creating by sweeping a curve or edge along a specified path. If Use Rigid 
Option is selected, the generating curve is not rotated to keep the same angle with the path but is rigidly translated 
along the path without rotation. The first two method accept a Draft Angle as the X coordinate of the SCC rotation. The 
following paths are possible: 
Along a curve User selects the curve and then the path before this command. 
Along the SCC Vector WCS coordinates used if checked in SCC dialog. 
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Rotating around an Axis SCC position and SCC vector determine the axis of rotation. The SCC Rotation angle for 
the X coordinate is used for the angle of rotation. 

 
Surfaces, Sheet-bodies, one-sided and two-sided faces 
Previous versions of AMPSolid created one-sided surface geometries instead of sheet-bodies with two sides. The 
current version creates two-sided sheet-bodies (now called surfaces) with all surface construction methods. Users 
don’t really need to worry about one-sided or two-sided surfaces. Unless you are creating a solid, it is simpler to have 
both sides of a surface visible. If you are using the Solid by stitching surfaces command, the sidedness of the 
surface is automatically adjusted when the solid is created. 

Create Surface by Covering closed curves (Create>Cover closed curves) 

This command creates a surface bound by a closed curve. The closed curve may be made up of individual curves or 
may be a single circle or ellipse. The curves do not need to be in the same plane. The edges of existing surfaces may 
be selected as edges curves for the surface to be covered. 
The curves may be selected in any order but must form a simple, closed, non-intersecting loop. The selected curves 
form the closed boundary of the surface that is created. 
a. Select the connected curves in any order using the EDGE/CURVE selector 
b. Select this option. 

Create Surface by skinning curves (Create>Skin through curves) 

This option uses a skin to cover curves (or edges) that are essentially laid out in one direction, the so-called U curve 
direction. 
As an example, the following graphic shows how three splines sitting in the z direction are selected, and a skin is 
created: 

  
To use this option: 

a. Create a series of curves. 
b. Using the edge filter, select the curves in the skinning sequence. Select at least curves to be skinned. 
c. Select this option. 

Create Surface using Skinning with Edge curves 

(Create>Two Direction Skin>Skinning with edge)  
This creates a surface from two edge curves and multiple skinning curves between the two edge curves. The diagram 
shows two edge and two skinning splines in the x and y directions respectively. The right hand diagram shows the 
generated surface. 

  
To use this option: 
a. Create two or more Edge curves essentially in the X direction. 
b. Create two or more Skinning curves between the edges, the first and last skinning curves should end at the 

endpoints of the edge curves. The middle skinning curves should end on the edge. 
c. Using Edge selection, select the edges first then select the skinning curves in order. 
d. Select this option. 
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Create Surface skinning multiple U and V curves 

(Create>Two Direction Skin>first half U method)  

This command creates a surface from multiple U curves and multiple V curves.  The number of U curves, nU, must 
equal the number of V curves, nV or be one less, nV-1. The diagram shows two U curves and two V curves converted 
into a surface. If more U and V curves are used, the inner curves must start and end at an edge curve. Also, where 
inner curves cross, they should intersect within the RESFIT geometry Tolerance. 

  
To use this option: 
a. Create two or more U skinning curves typically approximately parallel to each other. 
b. Create two or more V Skinning curves approximately parallel and approximately perpendicular to the U skinning 

curves. The first and last U and V skinning curves form the boundary of the new surface. The inner skinning V 
curves should end on the two U edge curves. The inner skinning U curves should end on the two V edge curves. 
Where inner curves cross, they should intersect. 

c. Using Edge selection, select the U skinning curves (nU = nV or nV-1) first then select the V skinning curves. Both 
sets of skinning curves are selected in the order in which the surface will pass through the curves. 

d. Select this option. 
 

Sweep Curve or Surface 

Sweeping Methods 

In AMPSolid, a generating curve can be swept to create a surface. Surfaces or closed curves can be swept to create a 
solid. The following methods are available for sweeping: 
1. Along a Curve 
• Select the generating curve or surface 

• The SCC Rotation X value is interpreted as a draft angle. 

• Select a path curve 

• Select Along a Curve menu option 
2. Along the SCC Vector 
• Make sure the SCC vector represents the correct sweep direction and distance 

• The SCC Rotation X value is interpreted as a draft angle. 

• Select the generating curve or surface 

• Select the Along the SCC Vector menu option. 
3. Around an Axis (SCC Position and Vector) 
• Make sure the SCC position and Vector define the axis of rotation 

• Set the rotation angle as the SCC Rotation X value 

• Select the generating curve or surface. 

• Select the Around an Axis (SCC Position and Vector) menu option. 
When a predefined curve is used, the surface is created as if the path curve had first been translated to connect to the 
generating curve. 
Use Rigid Option: When not checked, the sweep operation will rotate the generating curve or surface so that the 
angle between the curve and path remains the same. When checked, the generating curve or surface is swept using 
translation but no rotation as it moves along the path. 
Draft angle: The draft angle is the flare in or out angle as the curve is swept to form the surface. A positive draft angle 
is a flaring out sweeping, and a negative draft angle is a flaring inward sweeping.  Care must be exercised such that 
the draft angle does not create an invalid surface, otherwise it will create a solid creation error. The draft angle is 
typically 0, it is available for methods 1 and 2 and is stored in the SCC Rotation X value. 

Surface by sweeping (Create menu) 
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This option creates a surface by sweeping a curve. 
To use this option: 
a. Select the curve to be swept. 
b. Select one of the three methods of defining the sweep length and direction. When selecting multiple entities, 

remember to hold down the shift key. The three method available are: 
1. Along a curve. The path curve is the 2nd curve of the selection set. 
2. Along the SCC Vector. Instead of using a curve, use the SCC box's vector dialog box's vector (Vx,Vy,Vz) data. 
3. Around an Axis (SCC Position and Vector). This creates a circular sweep.  The SCC box's position is the origin 
of the sweep, and the vector is the axis of sweeping. Optionally, if you specify the rotation angle in the SCC box's 
rotation angle X position, it will indicate the sweeping angle. The default is to have a 360 degree sweep. 

c. Select the sweep curve option. 

 
 

Use Rigid Option: When not checked, the sweep operation will rotate the generating curve or surface so that the 
angle between the curve and path remains the same. When checked, the generating curve or surface is swept using 
translation but no rotation as it moves along the path. 
Draft angle: The draft angle is the flare in or out angle as the curve is swept to form the surface. A positive draft angle 
is a flaring out sweeping, and a negative draft angle is a flaring inward sweeping.  Care must be exercised such that 
the draft angle does not create an invalid surface, otherwise it will create a solid creation error. The draft angle is 
typically 0, it is available for methods 1 and 2 and is stored in the SCC Rotation X value. 

 

Sweep Use Rigid Option 

This option can be set to active by selecting it to toggle it on/off.  When not active, the sweep operation will rotate the 
generating curve or surface so that the angle between the curve and path remains the same. When active, the 
generating curve or surface is swept using translation but no rotation as it moves along the path. 

Solid 

Create Solid Primitives 

Solid Primitives 

Standard engineering solid bodies are usually combined with previously generated bodies to construct more complex 
geometric models. AMPSolid also provides tools to stitch together multiple faces to create a solid body. The SCC 
dialog’s smart snap option is typically used to simplify selection of the appropriate entities. AMPSolid can be used to 
create the following solids in one operation: 
Block: A rectangular solid 
Cylinder: A simple cylinder with a fixed radius 
Sphere: A sphere. 
General Solids>General Block: A solid between two parallel rectangles that can be different sizes. 
General Solids>General Cylinder: A cylinder (cone section) with a different bottom radius and top radius. 
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Solid body and surfaces can both be used in Boolean operation. For more information about Boolean Union, 
Subtraction, Intersection, refer to section on Boolean Operations for more details. 

Create a rectangular block (Create menu) 

This option creates a rectangular block by dragging diagonally from a starting point to define the bottom face and then 
dragging the resulting face to define the height of the block. 
To use this option: 
a. Set up the grid controls, if desired. 
b. Select the option. 
c. Position the lower left-hand corner of the bottom face at the origin of the block you want to create, then click the 

mouse left button. 
d. Move the mouse cursor diagonally to the opposite corner and click the mouse left button to create a bottom face. 
e. Move the height with the aid of the coordinate read-out and click to complete the block height definition, then click 

the left mouse button to indicate the block height. 
f. Repeat steps c through e to create additional blocks. 
After a block is created, the creation mode remains active and repeats the block creation mode till the mouse function 
is switched to other control.  To abort the block creation mode, click on one of the Selection modes on the Selection 
toolbar, or select "geometry/abort geometry tool". You can use Dynamic Rotate, Zoom, Pan or any of the Toggle 
Commands during construction and then toggle the command off to continue construction. 
 

Create a solid cylinder (Create menu) 

This option creates a cylinder by defining the bottom circle and then dragging the cylinder height in the z-direction of 
the WCS. When you are defining the bottom circle, the smart snap grid will automatically set itself to the bottom, and 
will then reset itself to reflect movement in the normal direction. 
To use this option: 
a. Set up the grid controls for smart snapping. By default the global axis is the WCS. 
b. Select the solid cylinder option. 
c. Position the bottom cylinder center by clicking the mouse left button to indicate the origin. 
d. Move the mouse cursor to the desired location for the cylinder size. Click to define the radius and create the 

bottom circle for the cylinder. 
e. Move the mouse cursor to cylinder height required, then click the left mouse button again to define the cylinder 

height. You can control cylinder height definition using smart snapping and the coordinate display using the SCC 
box control, if desired. 

f. Repeat steps c through e to create additional cylinders. 
After a cylinder is created, the creation mode remains active and repeats the cylinder creation mode till the mouse 
function is switched to other control.  To abort the cylinder creation mode, click on one of the Selection modes on the 
Selection toolbar, or select "geometry/abort geometry tool". You can use Dynamic Rotate, Zoom, Pan or any of the 
Toggle Commands during construction and then toggle the command off to continue construction. 

 

Create a solid sphere (Create menu) 

This option creates a sphere by defining the origin and dragging to define the radius. 
To use this option 
a. Set the intervals for smart snapping using the Edit menu’s grid control option 
b. Select the solid sphere option. 
c. Move the cursor to the point that you want to be the center of the sphere, holding down the control key to activate 

smart snapping if desired. 
d. Click the left mouse button to define the sphere center. 
e. Define the radius by moving the cursor to the position of the radius and click the left mouse button to indicate the 

position, using smart snapping if desired (holding the control key). 
f. Repeat steps c through e to create additional spheres. 
After a solid is created, the solid sphere creation mode remains active and repeats the sphere creation mode till the 
mouse function is switched to other control.  To abort the sphere creation mode, click on one of the Selection modes 
on the Selection toolbar. You can use Dynamic Rotate, Zoom, Pan or any of the Toggle Commands during 
construction and then toggle the command off to continue construction. 
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Create a general block (Create>General Solids menu) 

This option creates a general block that has two rectangular faces at top and bottom that are separated by a constant 
height. 
To use this option: 

a. Set up the grid controls. 
b. Select the option. 

c. Click the mouse left button to define one corner, and move to the another lower block corner and click the left 
mouse button to define the lower face by the. 

d. Move the mouse cursor to define the height. 
e. On the plane at the height, define the top face by selecting the two diagonal end points by making two mouse left 

button clicks. 
f. Repeat steps c through e to create additional general blocks. 
After a general block is created, the creation mode remains active and repeats the general block creation mode till the 
mouse function is switched to other control.  To abort the general block creation mode, click on one of the Selection 
modes on the Selection toolbar, or select "geometry/abort geometry tool". 
 
 

Create a general cylinder (Create>General Solids menu) 

This option creates a symmetric general cylinder. The cylinder has top and bottom faces of different radii. The top and 
bottom faces are separated by a constant height. 
To use this option: 
a. Select the option. 
b. Define the bottom face by clicking to position the center of the circle, then move the mouse cursor and click the 

left mouse button to define its radius. 
c. Define the height of the cylinder by moving the mouse cursor then set the height by clicking the lfet mouse button. 
d. On the plane at the height, move the mouse cursor to define the radius of the top face, then click the left mouse 

button to define the radius 
e. Repeat steps b through d to create additional general blocks. 
After a general cylinder is created, the creation mode remains active and repeats the general cylinder creation mode 
till the mouse function is switched to other control.  To abort the general cylinder creation mode, click on one of the 
Selection modes on the Selection toolbar, or select "geometry/abort geometry tool". 
 

Sweep Curve or Surface 

Sweeping Methods 

In AMPSolid, a generating curve can be swept to create a surface. Surfaces or closed curves can be swept to create a 
solid. The following methods are available for sweeping: 
4. Along a Curve 
• Select the generating curve or surface 

• The SCC Rotation X value is interpreted as a draft angle. 

• Select a path curve 

• Select Along a Curve menu option 
5. Along the SCC Vector 
• Make sure the SCC vector represents the correct sweep direction and distance 

• The SCC Rotation X value is interpreted as a draft angle. 

• Select the generating curve or surface 

• Select the Along the SCC Vector menu option. 
6. Around an Axis (SCC Position and Vector) 
• Make sure the SCC position and Vector define the axis of rotation 

• Set the rotation angle as the SCC Rotation X value 

• Select the generating curve or surface. 

• Select the Around an Axis (SCC Position and Vector) menu option. 
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When a predefined curve is used, the surface is created as if the path curve had first been translated to connect to the 
generating curve. 
Use Rigid Option: When not checked, the sweep operation will rotate the generating curve or surface so that the 
angle between the curve and path remains the same. When checked, the generating curve or surface is swept using 
translation but no rotation as it moves along the path. 
Draft angle: The draft angle is the flare in or out angle as the curve is swept to form the surface. A positive draft angle 
is a flaring out sweeping, and a negative draft angle is a flaring inward sweeping.  Care must be exercised such that 
the draft angle does not create an invalid surface, otherwise it will create a solid creation error. The draft angle is 
typically 0, it is available for methods 1 and 2 and is stored in the SCC Rotation X value. 

Sweep Closed curve / wire body to create Solid body (Create>Solid by sweeping menu) 

This option uses single closed curve or a closed wire-body to create a solid by sweeping along a direction. If multiple 
curves are used to form a closed generator, the connected curves should first be converted into a wire-body. 
To use this option: 
a. Select the single closed wire body or closed curve. 
b. Select the manner of sweeping from one of the three sweeping methods shown in the menu. The three method 

available are: 
1. Along a curve. This should be the 2nd curve of the selection set. 
2. Along the SCC Vector. Instead of using a curve, use the SCC box's vector dialog box's vector (Vx,Vy,Vz) data. 
3. Around an Axis (SCC Position and Vector). This creates a circular sweep.  The SCC box's position is the origin 
of the sweep, and the vector is the axis of sweeping. Optionally, if you specify the rotation angle in the SCC box's 
rotation angle X position, it will indicate the sweeping angle. The default is to have a 360 degree sweep. 

c. Select the option. 
Use Rigid Option: When not checked, the sweep operation will rotate the generating curve or surface so that the 
angle between the curve and path remains the same. When checked, the generating curve or surface is swept using 
translation but no rotation as it moves along the path. 
Draft angle: The draft angle is the flare in or out angle as the curve is swept to form the surface. A positive draft angle 
is a flaring out sweeping, and a negative draft angle is a flaring inward sweeping.  Care must be exercised such that 
the draft angle does not create an invalid surface, otherwise it will create a solid creation error. The draft angle is 
typically 0, it is available for methods 1 and 2 and is stored in the SCC Rotation X value. 

Sweep Surface to create a Solid (Create>Solid by Sweeping menu) 

This option uses a surface to create a body by sweeping. Note that a sheet face must be converted to a surface before 
it can be used for sweeping. 
To use this option: 
a. Select the surface. 
b. Select the sweep method from the three sweeping methods that are available. The three method available are: 

1. Along a curve. This is the 2nd curve of the selection set. 
2. Along the State Vector. Instead of using a curve, use the SCC box's vector dialog box's vector (Vx,Vy,Vz) data. 
3. Around an axis (State position and Vector). This is to create a circular sweep.  The SCC box's position is the 
origin of the sweep, and the vector is the axis of sweeping. Optionally, if you specify the rotation angle in the SCC 
box's rotation angle X position, it will indicate the sweeping angle. The default is to have a 360 degree sweep. 
Note that when options 1 or 2 is used, the user can optionally specify a draft angle of sweeping by enter the angle 
in the SCC box's rotational angle position 1st position (RotX). The draft angle is the flare in or out angle as the 
surface is swept to form the volume. A positive draft angle is a flaring out sweeping, and a negative draft angle is 
a flaring inward sweeping.  Care must be exercised such that the draft angle does not create an invalid volume, 
otherwise it will create a solid creation error. 

Use Rigid Option: When not checked, the sweep operation will rotate the generating curve or surface so that the 
angle between the curve and path remains the same. When checked, the generating curve or surface is swept using 
translation but no rotation as it moves along the path. 
Draft angle: The draft angle is the flare in or out angle as the curve is swept to form the surface. A positive draft angle 
is a flaring out sweeping, and a negative draft angle is a flaring inward sweeping.  Care must be exercised such that 
the draft angle does not create an invalid surface, otherwise it will create a solid creation error. The draft angle is 
typically 0, it is available for methods 1 and 2 and is stored in the SCC Rotation X value. 
 

Sweep Use Rigid Option 

This option can be set to active by selecting it to toggle it on/off.  When not active, the sweep operation will rotate the 
generating curve or surface so that the angle between the curve and path remains the same. When active, the 
generating curve or surface is swept using translation but no rotation as it moves along the path. 
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Other Solid Creation Methods 

Thickening A Surface into a SolidBody (Create menu) 

This converts a surface into an actual solid with the specified thickness. 
To use this option: 
a. Select the face using the body selector. If this is a surface from an older AMPSolid and can’t be selected by the 

body selector, use Modify>Surface Modifications>Convert face to sheet-body.  
b. Select this menu option. A menu box will popup to show additional controls: 

 
c. Specify the solid thickness desired. It is also possible to thicken the surface based on the direction of the 

thickening control. This will be use to place the newly generated solid above, below, or containing the original 
sheetbody. Note that the original surface will be disappearing since it is now converted into a solid volume. 

Solid by Stitching Surfaces (Create menu) 

This option enables you to stitch multiple surfaces into a single body.  If the selected surfaces form a watertight body, 
a solid is generated.  
If the surfaces do not create a watertight body, a body consisting of two-sided surfaces is created and a warning is 
generated. When a solid is subtracted from a body that looks like a solid but is made up of two-sided surfaces, only 
the region of the surface within the solid are removed. No edges are generated for the region inside the original 
boundary of two-sided surfaces. Use undo and fix up the surfaces so they form the boundary of a solid with no extra 
surfaces. 
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Entity Modification 

Rigid Modifications (Edit) 

Translate (Edit menu) 

 on the Measure toolbar 
This option applies the SCC vector as a translation transformation to any selected entities. Only top-level entities can 
be translated. 
To use this option: 
a. Enter the desired vector state value into the SCC or create the values using a distance measurement 
b. Select the entity or entities to be modified. 
c. Select this option. 
If the WCS checkbox on the SCC dialog is checked, the vector is interpreted in the current WCS coordinates. 
Using Translate with Measure Distance 
Using Translate after Measure Distance allows the user to translate the selected objects the same distance that was 
just measured. Follow these steps: 
a. Select the items to translate 
b. Select the Measure 2-pt Distance option 
c. Measure the distance to move the selected objects. Use the CTRL Right Button Up shortcut to snap to vertices. 

The vector distance measured is copied to the SCC Vector value 
d. Click the Translate button on the Measure toolbar to move the selected items. 

Rotate (Edit menu) 

 on the Measure toolbar 
This option applies the SCC angle as a rotational transformation to any selected entities. Only top-level entities can be 
modified. 
To use this option: 
a. Enter the desired angle state value into the SCC or create the values using an angle measurement 
b. Select the entity or entities to be modified. 
c. Select this option. 

Modify Entity Color (Edit menu) 

This option displays a color selection dialog box. If an entity is currently selected, the dialog highlights the color of that 
entity. You can then select or compose other colors to use when displaying the selected entity.  This function is 
normally used to make the model easier to see or to assign different colors to different regions of a model so that they 
can be selected using the entity selection color filter. 

Boolean Geometry 

Boolean Operations 

This option enables you to perform Boolean operations between any two selected bodies. Building a complex body in 
this fashion is known as constructive solid geometry. As shown below, the Modify menu and the Modify>Other 
Boolean menus provide several different  Boolean Operations: 
Subtract: Changes the first body to be the first selected body minus any region of the first selected body that is in any 
of the other selected bodies. A one-sided surface can be used to cut off part of a solid (see below). 
Union: Change the first selected body to include the solid volume of all the selected bodies (along with their 
boundaries). 
Other Boolean>Intersection: Change the first selected body to be the region inside (or on the boundary) of all the 
selected bodies. 
Other Boolean>Create Intersection Wire(Body): Create a wirebode at the intersection between the surfaces of the 
all the selected bodies. 
Other Boolean>Imprint: Similar to Create Intersection Wire(Body) except that the intersection curves are added as 
trimming curves to the faces of all the selected, intersecting surfaces. 
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In Boolean operations, a surface (sheet body) is also recognized as a body. For example, the union between a surface 
cutting across another body eliminates the part of the body behind the front face (the visible face) of the sheet body.  
As shown below, this subtraction mechanism is a convenient way to cut away a solid body using a surface. Use the  

  

Union of Bodies (Modify menu) 

This option replaces the first selected body with the union of the first and the second selected bodies. The union 
includes all points that are enclosed by either solid boundary or on either solid boundary. 
To use this option: 
a. Select the first body. 
b. Select other bodies to be united with the first body, holding down the shift key so that you can select multiple 

items. 
c. Select this option. 
After this operation, only the first body is displayed in the model window. The rest of the bodies are permanently 
deleted and removed from the system. 

Subtract body (Modify menu) 

This option subtracts a second selected body from a previously selected body. 
To use this option: 
a. Select the first body that (the one that you want to subtract from). 
b. Select the second body (the one that you want to subtract from the first), holding down the shift key so that you 

can select multiple items. 
c. Select this option. 
After this operation, only the remainder of the first body is displayed in the model window. The rest of the bodies are 
permanently deleted and removed from the system. 

Intersection of two bodies (Modify>Other Boolean menu) 

This option defines the solid that is common to both bodies. 
To use this option: 
a. Select the first body. 
b. Select the second body, holding down the shift key so that you can select multiple items. 
c. Select this option. 
Note that after the operation, only the first body will remain in the memory and will be the intersection body. The 
second body will be destroyed and removed from the system 

Create Intersection of wire body  

(Modify>Other Boolean menu>Create Intersection Wire(Body)) 

This option creates the body wire that defines the wire body created by the Boolean intersection. This is useful only if 
the intersection wire is necessary for subsequent operations, such as the construction of reference curves. 

Create Intersection and Imprint the Bodies 

(Modify>Other Boolean menu>Imprint) 

This option will intersect two bodies with each other, create the intersection profile, and then use the intersection to 
modify the topology of the bodies so each body will have the imprint of the intersection.  Unlike the "Create 
Intersection Wire" operation that just creates the intersection body wires as a separate entity, this operation actually 
partitions each body's face along the intersection.  The intersected bodies are all modified with this new intersection 
profile. 

Nonregular Boolean Option (Modify menu) 

A non-regular Boolean can include internal surfaces. This is necessary when a solid body is made up of multiple 
materials. The internal surfaces that separate the different materials must be included. 
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If this option is checked, the solid boundary (faces and edges) from multiple bodies will remain after the boolean 
operation. This allows the material interface to be preserved after the Boolean operation. 

Slice Body with WCS XY-plane 

Slice body (Modify>Slice menu) 

This option is located on the Edit menu, and slices the selected body using the XY plane of the WCS. There are two 
options. The first option slices on the basis of half the enclosing planes in the z-axis direction. The second method 
slices with an XY-plane passing through the WCS origin.  

 
The slice options are provided as a simple way to subdivide primitive solids. For example, the following diagram 
illustrates the result of three sequential slices of a sphere by halving and deleting a half. More complicated slicing with 
curved surfaces should be done by using sheet bodies with the Boolean operations provided by AMPSolid. 

 

Slice body in half with XY-plane 

(Modify>Slice>through Body center) 

This option uses the WCS XY-plane to slice the selected body into two halves. The limits of the body in the Z-axis are 
used as the basis for halving. 
To use this option: 
a. Rotate the WCS XY-plane to the required slicing angle. 
b. Select the body. 
c. Select the halving slice option. 

Slice body through the WCS origin 

(Modify>Slice>through WCS origin) 

This option slices at the WCS origin using the WCS XY-plane. 
To use this option: 
a. Position the WCS origin at the desired vertex. 
b. Rotate the WCS to the required slice angle. 
c. Select the body to be sliced. 
d. Select this option. 

Curve Modifications 

Convert curve to wire body (Modify>Curve(s) to Wirebody) 

This option enables you to convert curves into a wire body.  If multiple curves are selected, they must be simply 
connected. Each vertex should be connected to two curves. For open curves, the start and end vertex are only 
connected to one curve. 
To use this option 
a. Select the curve(s). Multiple curves can be selected by holding down the shift key while selecting the curves. 
b. Select this option. 

Usage: 

Connected curves can be converted to wirebody so they are treated as a single curve. This is useful for the 
Create>Solid by Sweeping>Closed Curve/Wire command.  
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Trim Curve 

Trim Curve (Modify menu) 

This option is used to remove unwanted portions of curves  by creating intersections between them and removing the 
remainder. 
The following curve trimming options are available on the Modify>Trim Curve menu: 
Trim One End – Trim one end of a curve based on a second curve. 
Trim Two Ends – Trim one curve based on 2 other curves. 
Trim One side – Trim one side of a curve based on a second curve. 
Trim 2 Curves – Trim 2 curves to a common intersection. 
Fillet 2 Curves – Fillet 2 curves at a common intersection using the SCC Vector X value as the Fillet radius. 
 
Note the Trimming operations only work on the ‘free’ end of an arc or circle. 

Trim One End (Modify>Trim curve menu) 

This option intersects the first selected curve with a second selected curve. The first curve is divided into two portions 
at the intersection point. When selecting the first curve, the side that is picked first will be retained, and the other 
portion is deleted. 
To use this option: 
a. Select the curve to be trimmed by selecting the side of the curve that you want to keep). 
b. Select the intersecting curve. 
c. Repeat steps a and b to trim other curves. 

Trim Two ends (Modify>Trim curve menu) 

This option intersects a selected curve with two other curves. The two end portions of the first curve are deleted. 
To use this option:  
a. Select first curve. 
b. Select the next two intersecting curves. 
c. Repeat steps a and b to trim other curves. 

Trim one side (Modify>Trim curve menu) 

This option splits the selected curve using another curve. The unwanted side of the first curve is deleted.  
To use this option: 
a. Select the first curve. 
b. Select the intersecting curve. 
c. Select the trim option . 
d. Select the unwanted portion of the first curve that will be deleted. 
e. Repeat steps a through d to trim other curves. 

Trim two curves (Modify>Trim curve menu) 

This option divides both the first selected curve and the intersecting curve. The sides of the two curves that are 
selected will be the sides that will be kept. 
To use this option: 
a. Select the first curve on the side that will be kept. 
b. Select the intersecting curve on the side that will be kept. 
c. Repeat steps a and b to trim other curves. 

Fillet two curves (Modify>Trim curve menu) 

This option creates a fillet by selecting the two intersecting curves near the intersection. The fillet radius is specified as 
the X component of the Vector in the SCC dialog. 
To use this option: 
a. Set the fillet radius as the SCC Vector X value. 
b. Select the first curve near the intersection. 
c. Select the second curve near the intersection. 
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d. Repeat steps a through c to fillet other curves. 

Surface Modifications 

Convert Surface to 1-sided (Modify>Surface Modifications menu) 

This command is used to prepare a surface to slice another surface or solid using the Boolean Subtract operation. See 
Boolean Operations for more details. Us the Reverse Face Side command to change the invisible side of the surface if 
it doesn’t match the section that you want cut away. Unless surfaces are selected with the body selector, the inside 
face of the surface is invisible. 
This converts the sheet body to a one-sided sheet such that the material side is the opposite of the side that is visible. 
To use this option: 
a. Select the sheetbody using the BODY selector. Rotate the sheetbody to other side if it is not visible. 
b. Select the convert option. 
c. Check that the face shows in the desired direction. Use the reverse option as necessary. 
 

Reverse Face Side (Modify>Surface Modification menu) 

This operation is used to change the invisible side of a one-sided surface. One-sided surfaces are used with the 
Boolean Subtract operation to slice part of a body using a surface. See Convert Surface to 1-sided for more details. 
To use this option: 
a. Rotate the sheet body until the sheet body face shows. 
b. Select the sheet body. 
c. Select the reverse option. 

Convert Surface to 2-sided (Modify>Surface Modifications menu) 

*This option should not be necessary unless you are loading a surface from a previous version of AMPSolid. This 
converts the sheet body to a two-sided surface.  This sheetbody will have not volume since now both sides are air/void 
sides. Two-sided sheet-body surfaces can be used for Boolean operations. 
To use this option: 
a. Rotate the picture until the one-sided face on the sheet body shows.  
b. Select the sheet body with the body selector. 
c. Select this option. 

Convert Face to SheetBody (Modify>Surface Modification menu) 

*This operation is only needed when loading older AMPSolid SAT files. The current surface construction operations 
create two sided SheetBodies.  
This converts a surface/face into a sheetbody that contains the volume information. 
To use this option: 
a. Select the face using the FACE selector. Rotate the face to other side if it is not visible. 
b. Select the convert option. 
c. Check that the sheetbody shows in the desired direction. Use the reverse option as necessary 
 

Solid Modifications 

Shelling a Solid (Modifications>Solid Modifications>Thick shell from a solid menu) 

This converts a solid into a hollow solid body with the specified thickness with optional control of each face' 
open/close/thickness controls. 
To use this option: 
d. Select the solid body using the BODY selector, 
e. Select this menu option. A menu box will popup to show additional controls: 
 
There are basically two way of doing solid shelling: 
Simplified Solid Shelling: In this method, no individual face control is necessary, and only the desired thickness is 
necessary. Enter the desired thickness in the Solid Wall Thickness box. A positive thickness will generate the 
thickness from the outer airside of the body, while a negative thickness will generate the thickness into the solid body's 
inner material side.  Care should be taken not to specify a thickness that could be thicker than the body's depth. Note 
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that when using this option, it is not possible to generate a solid wall model with certain face open, but the Advanced 
Specific Shelling will do so. 
Advanced Specific Solid Shelling: This is for more precise control of the shelling.  The wall thickness into the body 
and 

 
outside the body can be specified specifically. For each individual face, an optional control can be placed.  A check 
box option is available to shell only the solid faces with specified shelling controls only. This is convenient if you do not 
want to shell the whole body, and desire to shell only a few faces cluster together. To specify the control on a solid 
face, select the face (or faces) using the FACE filter, then select the Modify>Solid Shelling Face Control... menu. A 
face shelling control dialog box will show up: 

 
To skip the face during the solid shelling and generate an open area, check the "Do Not Shell The Face (Leave Open)" 
check box.  Otherwise, enter the desired inner and outer thickness for this face's shelling controls.  Additionally, it is 
possible to delete record associate with the selected face's shelling controls by checking "Delete the Shelling Control 
on the Face…" This will force this force to use the default Specific Solid Shelling control. A menu option "Reset All 
Faces' Controls" allows removing all face shelling controls and reset the Advanced Specific Solid Shelling to its 
default setting. 
 

Remove Small Solid Faces (Modify>Solid Modifications menu) 

This option allows the user to remove small surface features that are usually not necessary for finite element analysis.  
Imported CAD model often contains a lot of small features necessary for manufacturing purpose, but too small for 
affect analysis.  By selecting these faces and clicking on this option, the program will try to remove the selected small 
faces and then extend the neighboring faces to cover up the region. Typical use of this feature is to remove small 
fillet/chamfer surface, small surface holes, etc.  
It is import to realize that there may be no solution to the gap filling problem, or no solution using adjacent faces only. 
If the function detects these circumstances it issues an error and leaves the body unchanged.  Also, it may be 
necessary to take multiple steps to remove a cluster of small faces, e.g. one at a time, in order to successfully 
removing these unwanted small features. 

Sweep a Face (Modify>Solid Modifications menu) 

The Sweep a Face operation transforms the pre-selected faces through a transformation as specified by the SCC 
dialog box. The translation and rotation states are about the current WCS origin, and the translation is specified using 
the SCC box's vector state, and the rotation angles are based on SCC box's rotation angles (Rx, Ry, Rz) and the WCS 
axes. 
This operation is meant for modification of a face of a body after it has been constructed. Typical usage is for extrusion 
of a face, rotating of a face of a body, etc. 

Blend Solid Edges (Modify>Solid Modifications menu) 

This option creates round blends (fillets) along one or more edges based on the given blend radius. The blend radius 
is taken from the SCC Vector X component, and is specified in the local space of the body. To use this function, pre-
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select the edge to be blended, then click on this menu. If all edges that meet at a specific vertex are selected, the 
vertex is also blended.   Unless it is really necessary, it is not recommended for finite element analysis since the 
blending creates extra feature lines, and could cause unnecessary meshing refinement than is actually needed. 

Reverse Body (Modify>Advanced Solid menu) 

If a solid seems to have all the edges visible and the inside side of the surfaces visible, use this option to reverse the 
sides of the solid so that it becomes a normal solid. 
This option enables you to reverse an inside-out body.  An inside-out body refers to a whole space with a void defined 
by the body surface. This option is provided as a convenient way to convert the material side of a body. 
To use this option: 
a. Select the body you want to reverse. You can select multiple bodies by holding down the shift key during 

subsequent selections. 
b. Select the option. 

Regularize/Clean Solid (Modify>Advanced Solid menu) 

This option will clean up the pre-selected body for unnecessary vertices, edges, and faces for the solid definition.  This 
useful to remove the material interface in a solid body since it contains internal faces that are not necessary for the 
solid entity definition. It is also useful when importing model from other CAD/CAM/CAE modules, since they may 
contain duplicated faces, edges or vertices that are not necessary for modeling. 
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2D and 3D Shell Mesh Generation 

FlexMesh 2D Automatic Control 
This option generates the mesh automatically with the default or modified FlexMesh controls. The user is encouraged 
to make this default mesh generation to obtain a rough estimate as to the number of cells required as well as the 
improvements that may be possible through manual density refinement of the mesh. 
Operation  
a. Select the body or face to be meshed. 
b. Select the automatic cell generation option with default parameters. 
c. Select the sizes of the cell mesh expected, and execute the generation by pressing the OK button. 
d. Repeat the automatic mesh generation with different mesh size if necessary. 
Note that if only certain surfaces of a body should be meshed, the user can use the face size control to assign the 
surface to be skipped during the meshing process. For more information about controlling the mesh size on a specific 
face or edge, please consult the explanation in "Edge Size Control" and "Face Size Control" sections. 

FlexMesh 2D Control 
This control is used for Automatic mesh generation. It can be used for the following types of meshes: 

• 2D meshing on XY geometry – For two dimensional problems, the geometry must be in the XY plane. 
• Surface meshing – For meshing surfaces in 3 dimensions. 
• Pre-Solid Tri Faces creation – To create a triangular mesh on the surface of a solid. This surface triangular 

mesh is used by the Tetra (Solid) from Tri Faces command or the Hexa (Solid) from Tri Faces command to 
generate a solid mesh. For this option, the modes that can generate Quadrilaterals are disabled. 

 
This option allows the user to specify parameters for the whole cycle of mesh generation. 

 
The dialog box for the controls are displayed at the start of both the automatic and manual control mesh generations. 
The default size of the mesh is 1. The number of iterations of surface sniffing and cell smoothing is initially set to 3. 
The advanced control panel enables the postponement of edge sniffing. The warning diagnostics can be postponed in 
the process information mode. 
It is important to note that AMPS finite element system only uses XY plane for 2D or 2.5 D (axis-symmetric) model. If 
you want to generate a mesh for 2D (plane stress, plane strain, planar, or axis-symmetric) analysis, the face must be 
parallel to the XY plane. 
Approximate Size of Side 
This option controls the size the cell generated. During the generating process,  the program will try to make the side 
the cell to be approximately the size specified. 
Mesh Shape Control 
There are four different options for this control: 
Triangles Only: this will generate all triangles mesh.  If automatic tetrahedron volume meshing is desired after the 
surface meshes are generated, it is required to select triangular only surface meshing. 
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Mixed Quadrilaterals and Triangles: this will generate mixed mesh of quadrilaterals and triangles. This is the quickest 
way to produce mixed mesh.  
Quadrilaterals Only: this option will generate only quadrilateral elements. 
Quadrilaterals Major: this option generate as many quadrilateral cells as possible, and use as few triangles as possible 
to fill in the surface region. In general, this gives the best mesh quality. 
Use Global Curvature Refinement 
Curvature refinement allows automatic mesh refinement when the geometry curves or surfaces contain sharp 
curvature.  When this option is activated, the mesh generator will automatically decrease the mesh size trying to 
represent the geometry as close as possible.  Since in doing so, it will generate large amount of meshes than usual, 
two additional controls scheme are necessary: 

 
1) Mesh Curvature Refinement Ratio: this is the ratio of the largest distance from an element to the geometry 

surface divided by this element's size. As shown in the picture, it is the ratio of "Distance To Geometry" divided by 
"Mesh Size". This number must be between 0 and 0.5. The smaller the curvature ratio, the more elements will be 
generated when needed. To prevent fine meshes, you can also use the local curvature control associated with 
the individual face and edge, instead of using the global curvature refinement control. 

1) Minimum Mesh Size for Refinement: If you use this curvature control, you will also need to set the minimum mesh 
size, otherwise it will generate too many tetra/triangles. If you don't set the minimum mesh size, it will be 
automatically set to about 5% of the desired global mesh size. 

Cell Point Smoothing Control 
This option controls the whether to apply the nodal point smoothing process to the triangles and the quadrilaterals 
nodes. 

FlexMesh 2D Step 1 
This option generates the initial FlexMesh 2D background cells based on the control parameters.  The user is 
encourage to use the "Auto FlexMesh 2D" to generate the mesh instead of this manual step. If it is used, the user is 
responsible to continue to FlexMesh 2D if necessary.  When only triangular meshes are generated, the step 1 process 
will generate the first surface triangles. 

FlexMesh 2D Step 2 
In FlexMesh 2D step 2, if the mesh shape specified is not triangle, the desired quad or mixed meshes are generated in 
this step. This step 2 process can be selected only after step 1 process has finished. 
 

FlexMesh 2D Step 3 
In FlexMesh 2D step 3, the mesh is smoothed to improve their quality. This step 3 process can be selected only after 
step 2 process has finished. 

FlexMesh 2D Vertex Mesh Control 

 
This option allows you to control the size of the mesh near the vertex of a body.  During the FlexMesh 2d generation, 
the program will try to generate the cell with sides approximately equal to the specified size around this vertex. Once 
this size attribute is set, it will remain in the graphic entity unless you reset it by selecting the parent body entity and 
use the "Reset Mesh Size" control to remove it. If you save the geometry in a file, the setting is also saved.  You can 
specify the setting on multiple vertices (using the multiple selection by holding down the shift key) and specify the size 
on these selections. 
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FlexMesh 2D Edge Mesh Control 

 
This option allows you to control the size of the mesh along an edge. During the FlexMesh 2d generation, the program 
will try to generate the cell with sides approximately equal to the specified size. Once this size attribute is set, it will 
remain in the graphic entity unless you reset it by selecting the parent body entity and use the "Reset Mesh Size" 
control to remove it. If you save the geometry in a file, the setting is also saved.  You can specify the setting on 
multiple edges (using the multiple selection by holding down the shift key) and specify the size on these selections. 
The local curvature refinement is useful when the global curvature refinement control generates too many meshes. In 
such case, the user can turn off the global curvature refinement, and specify the local curvature refinement only at a 
specific edge. For more details of the curvature refinement ratio, please refer to the FlexMesh 2D Control section. 

FlexMesh 2D Face Mesh Control 

 
This option allows you to control the size of the mesh on a face of a body.  During the FlexMesh 2d generation, the 
program will try to generate the cell with sides approximately equal to the specified size. Once this size attribute is set, 
it will remain in the graphic entity unless you reset it by selecting the parent body entity and use the "Reset Mesh Size" 
control to remove it. If you save the geometry in a file, the setting is also saved.  You can specify the setting on 
multiple edges (using the multiple selection by holding down the shift key) and specify the size on these selections. 
The local curvature refinement is useful when the global curvature refinement control generates too many meshes. In 
such case, the user can turn off the global curvature refinement, and specify the local curvature refinement only at a 
specific edge. For more details of the curvature refinement ratio, please refer to the FlexMesh 2D Control section. 
 

FlexMesh 2D Position Mesh Control 

 
This option allows you to control the size of the mesh at a specified position of a body.  It is very similar to the vertex 
meshing size control, except this position can be anywhere in the space (either inside or outside the body). During the 
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FlexMesh 2d generation, the program will try to generate the mesh with sides approximately equal to the specified size 
around this position, and will transition into the global mesh size setting once the meshing process is far away from the 
point specified.  
Once this size attribute is set, it will remain in the graphic entity unless you reset it by selecting the parent body entity 
and use the "Reset Mesh Size" control to remove it. If you save the geometry in a file, the setting is also saved.  You 
can use the Add/Update/Delete selection after you select the entry to perform the desired operation. 

FlexMesh 2D Line Mesh Control 

 
This option allows you to control the size of the mesh along a specified line segment of a body.  It is very similar to the 
edge meshing size control, except this line segment can be anywhere in the space (either inside or outside the body). 
During the FlexMesh 2d generation, the program will try to generate the mesh with sides approximately equal to the 
specified size along this line, and will transition into the global mesh size setting once the meshing process is far away 
from the line segment.  
Once this size attribute is set, it will remain in the graphic entity unless you reset it by selecting the parent body entity 
and use the "Reset Mesh Size" control to remove it. If you save the geometry in a file, the setting is also saved.  You 
can use the Add/Update/Delete selection after you select the entry to perform the desired operation. 

Select Face/Edge/Vertex by Number 

 
When the surface/tetra mesh generator is running, sometimes it will encounter some difficulty and will inform the user 
suggestive actions associated solid model entities.  It usually uses a number to identify the face, edge or vertex. To 
find out their relative location, this dialog box allow the user to select the entity by this type of number, order, or tag. 
The Add To Selection button is useful when multiple selections are needed from several selection by number. 
 

FlexMesh 2D Mesh Control Reset 
This option removes all, if any, point, line, vertex, edge or face size setting of a given geometric body entity selected.  
This is basically to clear the entity body selected of any associated meshing size controls. 

FlexMesh Attribute Control 

The FlexMesh Attribute dialog is used to assign an attribute value to selected cells or cell points.  When assigned, 
AMPSolid will transfer the assigned attribute value to the current OLE server module during the FlexMesh mesh export 
stage.  The attribute enables you to attach either boundary conditions or material data to the mesh.  For convenience, 
the FlexMesh Display control is automatically show on the screen at the beginning of the FlexMesh mesh export 
process. 
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This dialog provides several options: 
1. Initialize the attribute to ALL of the cells or cell points: Select this option if you want to initialize the cells to an 

attribute value as shown in the edit box.  The Action Type selection button determines whether this assignment is 
applied to cells or cell points. 

2. Assign attribute to the displayed cells/cell points: When using this option, displayed cells or cell points are 
assigned the currently specified attribute value.  You can use the options on the FlexMesh Display Control dialog 
to control the display region. 

3. Highlight cells/cell points with the specified attribute value: Using this option shows you any cells or cell points 
with the specified attribute value. 

4. Assign the attribute to the selected cell point: When using this option, displayed cell points are assigned the 
currently specified attribute value. The cell point selection vertex should be turned on before using this option. 
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3D Tetrehedron and Hexahedron Mesh Generation 

Tetrahedron Mesh Generation 
AMPSolid uses a robust Tetrahedron mesh generator to provide the user with a simple and 
fast automatic tetra mesh generation.  Usually, there is no need for the user to specify any 
further meshing information other than perform the initial surface triangular meshes.  If 
necessary, spatial mesh density can be specified along a curve, at a point, or over any internal 
or external solid surfaces.  

Tetra Volume Meshing Procedure 
The tetrahedron generation is initiated as follows: 
1. Use FlexCell 2D/Tetra/Hexa first create a triangular surface mesh. There are several 

surface triangular mesh controls that can be used to control the desirable surface 
triangular mesh. For details, please refer to the 2D and Shell Mesh Generation section. 

2. After the surface triangular mesh has been generated to satisfaction, use the “Generate 
Tetra from Tri Faces” sub-menu to activate Tetrahedron automatic meshing. 

3. The Tetrahedron mesher generates the volume meshes. If it runs into any difficulty, it will 
inform the user about suggestive action in the Message Box. At the conclusion of the 
mesh generation, the user uses the File/Export Mesh to export the mesh to AMPView FEA 
pre-/post-processing.  The export function will support 2nd order tetrahedron elements if 
desired. 

 

Hexahedron Meshing from Surface Triangle Meshes 
The hexahedron generation from the surface triangle meshes is initiated as follows: 
4. Use FlexCell 2D/Tetra/Hexa first create a triangular surface mesh. Several surface 

triangular mesh controls can be used to control the desirable surface triangular mesh. For 
details, please refer to the 2D and Shell Mesh Generation section. 

5. After the surface triangular mesh has been generated to satisfaction, use the “Generate 
Hexa from Tri Faces” sub-menu to activate hexahedron automatic meshing. 

6. The hexahedron mesher generates the hexa meshes from surface triangular meshes. If it 
runs into any difficulty, it will inform the user about suggestive action in the Message Box. 
At the conclusion of the mesh generation, the user uses the File/Export Mesh to export the 
mesh to AMPView FEA pre-/post-processing.  The export function will support 2nd order 
hexahedron elements if desired. 
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3D FlexMeshl Hexahedron Mesh Generation 

Mesh Generation 

AMPSolid provides a FlexMesh™ algorithm for hexahedron high quality volume mesh creation. The term FlexMesh 
refers to the "Flexible Meshes" generation method used by AMPSolid. This mesh generation first creates 3D 
rectangular cells that enclose the selected body. These cells can then be stretched or squeezed to match the 
geometry of the model. Any extraneous cells are removed and the remaining cells are compressed onto the surface of 
the body by projecting the cell surfaces onto the body surface (known as "surface sniffing"). Surface sniffing also 
locates certain cell points on the edges of the body (we call this edge sniffing). These cell points are smoothed by 
edge, surface, and volume location, respectively. You can iterate through the surface projection and cell-smoothing 
processes until you obtain the results you want. 
For simple bodies, the mesh can be generated quickly and automatically. For complex geometries, manual 
optimization during various phases of the FlexMesh process can produce substantially improved results, so we have 
subdivided the process into four steps and provided a number of tools that can be used at each step to ensure the 
generation of a good mesh. These steps follow: 
1. Step 0. In this step the automatically generated box that encloses the model is subdivided into a number of cells 

(by default, 5X5X5). AMPSolid then provides a mapping of the enclosing mesh. This mapping is controlled by 
third order Lagrangian polynomials which give rise to 4 X 4 X 4 control points. You can move the control points on 
a plane, line, or as individual vertices to control the cell distribution and allow the containing cells to be shaped 
into arbitrary shapes to fit the natural shape of the model. 

2. Step 1. This step marks each of the cells as an inside or outside cell. Outside cells are deleted. In preparation for 
the next step, tools are provided for positioning cell nodes on specific locations of the geometric body. You can 
use these tools to position cell nodes on surfaces and edges, providing more granular control than in the previous 
step, where cells were located strategically. 

3. Step 2. This step locates the outside cells on the surface by projecting them onto that surface. Cell nodes that are 
located on edges are processed by local loop searches through the cell topology. This search is the major 
determinant in a successful mesh generation. The cell nodes are then determined by a cell-smoothing loop. This 
step can be repeated to provide a better mesh. 

4. Step 3. This final mesh generation step includes cleaning up the display and selection of boundary conditions. 
The mesh information is finally written out in the format specified by the user, or can be exported directly to the 
AMPSol program for Finite Element Analysis. 

All these steps can be repeated as many times as desired.  In complex mesh generation, it is hard to predict the 
optimum cell density distribution, and it is therefore often necessary to cycle between steps 1 and 0 to remove or add 
more cells as needed, then proceed to steps 2 and 3.  Even after step 3 is finished, it is possible to manually adjust the 
cell distribution, reinitialize step 2, and repeat step 3 for better mesh distributions.  
Version 2.0 of AMPSolid incorporates a newly added automatic hexahedral element generation and regularization 
features, and the ability to blend in mixed pyramid and tetrahedron elements if desired.  The improved algorithm 
relaxes the original hexahedron element generation criterion, and generates the hexahedron elements based on the 
initial specified cell size, and selectively skips fine geometry features that are below the specified initial cell size.  
These fine solid features, usually are for manufacturing purpose, are usually not desired in the finite element analysis.  
As such, the user has full control of the geometry feature filtering by changing the initial cell sizes distribution, and can 
easily refine them to capture additional desired geometry feature using FlexMesh's internal cell divide/refinement 
control. 
The regularization process of the hexahedron elements then try to smooth the elements based on its distortion and the 
geometry restrictions.  This process is performed in the FlexMesh Step 3 stage, and is most useful when there are 
concaved inward geometry surface existing in the model, and concaved inward elements are unavoidable.  By default, 
this smoothing process is automatically, and is located is in the FlexMesh3D control, under the advanced control 
"Optimal Element Smoothing".  When this options is used, all hexahedral elements will be checked against distortion, 
and then automatically smoothed to a good valid element based on the element's Jacobian calculations.  A 
customized steepest decent searching algorithm specialized for element shape regularization is implemented to 
relocate the nodes to form a best element shape with the least node movement, and the speed is fast enough for 
practical large mesh. 
If the precise geometry is desired without resorting to the element smoothing when there is a concaved element 
surface, the hexahedron element is broken down into 6 pyramid elements.  Each pyramid is formed by connecting the 
center of the hexahedron element, and the 4 corner points of the original hexahedron's element face.  A fast numerical 
mapping calculation is used to identify the pyramid with the cancaved inward face.  For such pyramid, it is further 
divided into two 
tetrahedron elements by connecting the opposite corner of the quad face corner points.  The choice of the this 
pyramid-tetrahedron splitting is based on the orientation of the concave surface.  Using this approach, only a small 
amount of the hexahedron elements breakage are necessary, and can be selectively healed back to a hexahedron 
element if desired. 
Using this split-heal process, we can extend the FlexMesh algorithm into mixed element meshing easily, and the data 
keep very compact and effective. 
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Note that this new method is best used when there are enough initial cells specified.  Otherwise, if too many geometric 
model features are neglected, the results may not be undesirable.  And if less elements are desired, the user can 
always guide the FlexMesh algorithm for more control in element size distribution, as was proposed in the original 
semi-automatic meshing process.  In other word, this new method always acts as a default smart guidance, and will 
always allow manual override if desired. 

 

3D Auto Hex Meshing 

(Automesh>3D Auto Hex Meshing & FlexMesh/Solid>Auto FlexMesh 3D) 

Auto Hex Meshing automatically performs steps 1, 2 and 3 of the FlexMesh/Solid menu. The parameters for the mesh 
are set by the FlexMesh Controls. 
 
 

FlexMesh Control 

FlexMesh controls 

This option allows you to specify parameters for all of the steps in FlexMesh/solid mesh generation. 
The dialog box for the controls is displayed at the beginning of both the automatic and manual control mesh 
generations. 
The default number of cells is 10x10x10. The number of iterations of surface sniffing and cell smoothing is initially set 
to 3. 
The advanced control panel lets you postpone edge sniffing. Warning diagnostics can be postponed in process 
information mode. 
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Approximate No of Cells 

The default cell density for FlexMesh Step 0 meshes is 5x5x5. 

Approximate Cell Size 

This option enables you to enter the desired cell size instead of the number of cells to be created during FlexMesh 
Step 0 mesh generation.  If this option is used, any values entered in the cell number control will be ignored.  The 
minimum and maximum cell size option is currently used for reference only; they are currently not used in the 
FlexMesh process. 

Vertex Sniffer 

FlexMesh uses a vertex sniffer to identify the corners in your model, and assign cell points to these geometric points.  
Using this option ensures that every geometry point will be matched to a cell point or a finite element node. 
The "Feature Point Only" option is a option reserved to ensure that the topology of the cellular structure will match the 
geometric layout.  In FlexMesh, the "Feature Point" refers to a surface cell point that has only 3 or 5 neighboring 
surface cell points.  Examples of such cell points are cell corners and cell points at the intersection of 3 surface cells.  
When the "Feature Point Only" option is selected, the FlexMesh process will only match geometry points to these 
Feature Points, and will not use its default closest-proximity search criterion.   The highlighted points in the following 
figure are the cellular Feature Points.  This example geometry could be meshed automatically if the "Feature Point 
Only" option is selected, but would need manual adjustment in the standard proximity projection process, moving 
some cell points to guide the FlexMesh process. 



AMPSolid Reference Manuall 

60 

 

Edge Sniffer 

The Edge Sniffer option is used to provide information to the FlexMesh process. This enables the FlexMesh process to 
respect geometric edges and to ensure that the body edge will be matched by a series of interconnected cell sides or 
finite element sides.  When this option is selected, the cell point geometry projection process used in FlexMesh mesh 
generation will first search out cell sides and ensure that these are continuous in order to represent the geometry 
edge.   In some cases, the automatic search process can not recognize complex features or the proximity projection 
algorithm may create undesirable matches. In this case, manual intervention will be necessary.  Using cell point 
assignment or moving the initial cell point position will quickly help the FlexMesh process identify the most desirable 
matches. 
If the "Smooth Edge" option is selected, the FlexMesh process will automatically adjust cell points along the geometric 
edges so that these cell points will be equally spaced parametrically. 

Cell Recognition Rules 

Neglect Inactive Cells: During the FlexMesh Step 1 process, extraneous cells (cells that are outside the geometric 
body) are removed from further processing.  These cells become inactive.  However, it may be desirable to activate 
them later in the cell density adjustment stage. Because searching for these cells during the cell projection stage is 
computationally expensive, the default is to ignore the inactive extraneous cells.  Turning off this option and then 
performing the FlexMesh Step 1 process again enables AMPSolid to recheck all currently inactive cells to see whether 
they should be reactivated. 
Neglect Zero Intersection Surface Cells: It is usually easy to determine whether a cell is inside or outside the body 
of a model. When a cell touches the surface of the model at a single point which therefore has no volume of physical 
intersection, the default option is to neglect these cells and mark them inactive. By turning off the "Neglect Zero 
Intersection Surface Cells" option, you can force these cells to be considered in the mesh generation process. 
Fast Cell OutCode Check: During FlexMesh processing each cell is examined to determine whether it is inside or 
outside the geometry body of your model. Such checks are computationally expensive. To speed up these 
calculations, the FlexMesh process uses a fast average cell center calculation to check whether a cell is inside the 
body or not. When the mesh cells are very coarse, this check may be insufficient. By disabling this option, a more 
extensive ray firing penetration criterion is used to check the cell’s location. 
Reset Prior to Surface Sniffing: This control mainly allows the user more precise control in the manual operation 
mode to incrementally process the step 2 surface projection. If this option is on, all recognized surface features such 
as edges and points are discarded, and the step 2 process starts from a fresh sniffing. 
Process Displayed Cells Only: Checking a cell’s outcode and cell point positions to determine whether a cell or a 
cell point should be included in the calculations is computationally expensive. To speed up the calculation, FlexMesh 
limits this computation to only the cells that are displayed.  This is very useful when large and complex cells are active.  
You can use the "FlexMesh Display Control" box to limit this calculation to a selected displayed portion of your model. 
If this flag is active, FlexMesh calculations will only be performed on the displayed cells and the associated cell points. 
Verify Cell During Dragging: When cell points are modified by using the "Drag Cell Plane/Line/Point" graphic tools, it 
is likely that the translation applied by dragging cells will cause some cells to overlap.  To avoid such problems, the 
FlexMesh process will internally check whether dragging transformations are valid and thereby automatically prevent 
collapsing or overlapping cells. 
Optimal Element Smoothing: After the cells have been assigned and projected, some cells will have a distortion that 
is not useable for finite element use. This is usually referred to as bad geometry mapped element, or bad Jacobian 
ratio.  When this options is active, the program will go through a smoothing process that will try to bring the shape of 
the element back to the acceptance level to AMPSol processor.  It uses a steepest decent approach to adjust the cell 
corner points so the least movement will produce the acceptable shape.  
Since this smoothing process is fairly computational expensive even after we optimized the calculation procedure, the 
program internally will perform only necessary cycles of adjustments. For some extreme cases, this may not be 
enough.  In such case, after the automatic process or step 3 is completed, the user is advised to use the "FlexMesh 
Display>Show Distorted Cells" option to confirm that all cells pass the Jacobian check.  If there are still cells/elements 
that are not smoothed enough, performing multiple FlexMesh step 3 process with this option on will cure such 
problems. We have observed that in all cases, nearly all cells will be regularized when this 2nd Step 3 process is 
performed again. 
Use Mixed Tetra, Penta, Pyramid: when this options is selected and the cell contains distorted shape, and the 
Optimum Element Smoothing is not used, the program will convert the distorted hexahedron element into combination 
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of tetra and pyramid elements.  Normally, the Optimum Element Smoothing is suggested, but it will allow the elements 
not following the geometry precisely if distortion smoothing is used.  Using this option, the geometry is preserved – in a 
discrete finite element sense, but at the penalty of generating mixed elements that some finite element programs may 
not accept.  
Generate Tetra Mesh: when this options is selected and the cell contains distorted shape, and the Optimum Element 
Smoothing is not used, the program will convert the distorted hexahedron element into tetrahedron elements. Using 
this option, the geometry is preserved – in a discrete finite element sense of all tetrahedron elements.  

Surface Smoothing 

FlexMesh uses a Laplacian smoothing process to eliminate crooked edge corners.  This is an iterative process that, by 
default, will perform 3 full cycles of smoothing.  This is generally sufficient enough for most problems, but can be 
increased or decreased during the FlexMesh process. 
Surface smoothing calculations require expensive surface projection and Laplacian smoothing calculations.  To speed 
up this process, AMPSolid provides a fast surface projection algorithm to expedite the surface projection search. If 
activated, this algorithm reuses the projection points from each previous cycle as a starting point to compute the 
current surface projection. This generally increases the speed of the smoothing process, but may cause undesirable 
projections in cases where the body has a very dense surface pattern in a small region. In these cases, this fast 
projection option should be turned off. 

Interior Smoothing 

FlexMesh resolves interior cell meshing issues by solving a Laplacian differential equation. These equations can 
generally be solved using an interactive approach, usually with limited iterations required for meshing purposes. The 
default setting is 3 iterations. The smoothness of the interior cells can be improved by increasing this limit or by 
performing the FlexMesh Step 3 process several times until the desired results are achieved. 

Cell Point Calculation Method 

There are currently two basic techniques in guiding the FlexMesh projection and mapping. 
FlexMesh Ray Firing: This is the default technique. The method projects a ray from every FlexMesh surface point into 
the body being meshed.  Depending on the point of the ray touches the body, it then decide how to place the surface 
cell points.  This technique is the most general approach, since the geometry may contain thousands of features that 
are critical for discrete finite element simulation with finite amount of elements.  Using this approach, the geometry is 
captured in a discrete sense, and only features that are bigger than the element size specified are captured.  
FlexMesh Proximity: In certain situations when the geometry contain very few distinctive features (edges and points), 
and the user like to manipulate the cell position manually after the initially cell placement, this method will try to follow 
the geometry feature and try to project the surface cell points.  Basically, the program will search all surface features 
(edges and points) and try to identify the nearest surface cell point that can be used to represent the feature.  If 
enough cells are provided, this is usually fairly automatic.  But if the cell amounts used is low, or the geometry contains 
too many refined features, following these feature edge may cause problems, and the program will stop, and try to tell 
the user the feature edges that it can not follow.  The user, in such case, will need to guide the process by moving the 
desired cell point near the feature edge so the edge feature can be followed.  

FlexMesh Control Point Order 

The FlexMesh bounding box is a geometric box used to enclose the selected body during the FlexMesh initiation 
process.  You can grab and drag the box’s control points to shape the box to reflect the approximate size, geometry, 
and the shape of the body – this initial flexibility is part of the reason that this technique is termed the FlexMesh 
method. 
The control points of the bounding box can have either a 3x3x3 distribution or a 4x4x4 distribution. These two 
schemes correspond to the polynomial orders of 2 and 3. The default value is to use the higher order of 3 or 4x4x4 
control point for geometric control.  

Smart Initial Cell Placement 

When this option is activated, during the initial cells placement, the program will try to align the cell plane such that 
they form the best approximation.  This alignment is based on the initial uniform cell distribution, and will only align 
with the recognizable geometric plane and point. This will usually improve the quality of the cell through the better 
initial positioning. 

FlexMesh Step 0 

FlexMesh Step 0 

This option creates a rectangular box that encloses your model and populates it with cells. Cell positions can then be 
modified using AMPSolid’s cell plane, line, or individual point controls. 
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To use this option: 
a. Select the body to be meshed. 
b. Select FlexMesh Step 0 to generate the enclosing box and cells. 
c. Move any cells that you want to change to the position you desire.  

Drag Cells along WCS planes 

These options move a selected cell plane in an axial direction. By clicking any cell point on the cell plane, the whole 
cell plane is highlighted and can be moved in the direction normal to that plane.  
To use this option: 
a. Make sure the "Pickable Cell Points" option is selected. If it is not, you will not be able to select cell points.  You 

can easily select this option from its toolbar icon. 
b. Rotate the view so that the cell plane is roughly normal to the screen. 
c. Select the FlexMesh menu’s "Drag Cell Plane" option, and select the "Along Dir. 1", "Along Dir. 2", or "Along Dir. 

3 direction. 
d. Select a cell point and cell plane, and drag the highlighted plane. All cell points on that plane will be modified. 
e. Repeat steps c and d as needed to modify any other cell planes.  If you have to rotate the view to improve your 

view of the cell plane, make sure that you reselect the "Drag Cell Plane" toolbar item to re-enable it before 
attempting to move other cell planes. 
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Drag Cells on lines normal to planes 

This option moves a selected line of points in a direction normal to a plane. This line can be positioned to pass through 
any point in the plane. Cell placement for mesh generation can often be improved by selecting an orthogonal 
projection as shown. 

 
To use this option: 
a Make sure the "Pickable Cell Points" option is selected so that you can select cell points.  This option can easily be 

selected from the toolbar icon. 
b Rotate the view so that the cell line is roughly normal to the view screen.. 
c Select the Drag Cell Line option. 
d Select any point along a cell line to highlight that entire cell line. 
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e Repeat steps c and d to modify any additional cell lines. If you have to rotate the view to improve your view of the 
cell plane, make sure that you reselect the "Drag Cell Line" toolbar item to re-enable it before attempting to move 
other cell lines. 

  

Drag Cell Points in Axis Direction 

This option allows individual points to be picked and moved to another position. The movement is restricted to a 
selected axis direction or to the direction of the SCC Vector State. 

Mapping of FlexMesh 

Initial meshes are generated within a bounding box that encloses your model. AMPSolid maps all of the meshes by 
interpolation with a cubic Lagrangian Polynomial in three directions. This creates 64 control points. The following 
illustration shows a planar view of the control points for a bounding box rotated 45 degrees about the Z-axis. This 
plane view only shows the 16 control points for a face.  

 

 
Dragging the vertical lines of these control points enables you to generate the isoparametic mapping of the mesh. 

FlexMesh Step 1 

FlexMesh Step 1 

This FlexMesh step finds all cells that are outside the physical body of your model’s geometry and deletes them. For 
internal purposes, this FlexMesh step also marks the surface cell points. 
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Hardwiring of cells 

This option allows the user to specify how cells will be projected onto the body surface of your model. Cell points can 
be assigned to vertexes, edges, and faces. 
This command provides the following options: 

 

Assign cell point to Vertex 

This option assigns a cell point to a vertex. 
To use this option: 
a. Select the cell point. 
b. Select the vertex while holding down the shift key in order to select both entities. 
c. Select the option. A line will show the projection of the point to the surface vertex. 
Using this option guarantees that the cell point will be the only point assigned to that geometric vertex after cell to 
surface projection. 

Assign cell points to edge 

This option selects a sequence of cell points and assigns them to an edge. This can be very useful in certain cases 
because fitting the surface mesh to the edges determines the success of subsequent meshing of complex shapes. 
To use this option: 
a. Select a sequence of cell points. 
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b. Select an edge of the body. 
c. Select this option. The drop lines identify the projection of the points to the edge. 

Assign cell points to face 

This option selects a number of cells and assigns them to a face. The location of that assignment is determined by 
normal projection to the surface.  After this assignment, the cell points assigned will not be permitted to snap to other 
geometric faces. 
To use this option: 
a. Select a number of cell points 
b. Select a face on the body. 
c. Select this option.  

Clear cell point assignments 

This option clears out any of the previously assigned cells including those assigned by any previous FlexMesh Step 2 
operations. You can use this option to clear all or a portion of the current cell point assignments in your model. 
To use this option: 
a. Select a number of cell points 
b. Select this option to clear the assignment of the selected cell points. 

FlexMesh Step 2 

FlexMesh step 2 

This FlexMesh step projects the boundary points to the surface and smoothes the resulting mesh. This step 
encapsulates the basic mesh generation engine. The setting in the FlexMesh dialog box control the number of times 
that this step is automatically repeated to improve the projection and generate a smoother mesh. 
To use this option: 
a. From the FlexMesh Settings dialog, select the number of times that this option should iterate. 
b. Select this option. 
This option can also be used if the user manually modifies the cell point position and these points need to be re-
projected. This usually occurs when the default projection is not desirable, and the user desire to change the cell 
position for better mesh distribution. 

Undo step 2 assignments 

Edge and surface assignments can be undone after step 2 to enable you to assign better FlexMesh positions and then 
repeat step 2.  Selecting this option will clear all projections, and reset the cell to the original state before Step 2 
began. 

Reset edge assignment 

This option resets the geometric edge assignment of any cell sides. Edge assignments are fixed once they have been 
assigned by a previous iteration of the FlexMesh Step 2 process. It is sometimes desirable to remove the current edge 
assignments and redo the step 2 projection again. 
To use this option: 
a. Examine the assignment of cell points around the edge. 
b. Select the geometry edge 
c. Select this option. 

The edge stringing process 

The edge sniffing process starts with the selection of a point on the surface that is closest to the end of an edge (or 
which is assigned at the edge). Paths along the FlexMesh surface are examined to discover that path which leads to 
the point closest to the other end of the edge. We call this the edge stringing process. This is the most important step 
in recognizing the geometric features of a model. 

Failure of edge stringing process. 

When an edge stringing process fails during step 2, the program recovers the error and highlights the edges that failed 
during the stringing process.  This simplifies determining why the FlexMesh failed, providing cell point location 
adjustment guidelines and hints as to improved cell assignments to vertex, edge or face. 

Remove Line of corner cells 

Cylindrical solids tend to generate cells that almost have re-entrant faces on the surface. AMPSolid provides a means 
of improving the mesh by removing a line of cell and fusing the two remaining faces. The Remove Two-face Cells 
option may be selected on the FlexMesh Options menu: 
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To use this option after completing FlexMesh Step 1: 
1. Turn on the vertex filter and select the corner point of the line of cells that will be removed. 
2. Select the Remove Two-Face Option/Along Dir 3 option. 
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This results in a FlexMesh mesh similar to that shown above. Note that this is an unstructured mesh. 
You can now re-run FlexMesh Steps 2 and Steps 3 to obtain a mesh like the following: 

 
In your resulting mesh, the corner column of cells will have been eliminated and the mesh aspect ratio will have been 
improved. Curved cell faces along the cylindrical axis direction indicate that the surface smoothing iteration has not yet 
converged. 
You can now improve the surface face alignment with the cylindrical axis by undoing FlexMesh Step 2 and using the 
FlexMesh Options dialog to increase the number of surface smoothing iterations from the default 3 times to something 
on the order of 9 times. This produces a mesh similar to the following: 
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FlexMesh Step 3 

FlexMesh step 3 

This FlexMesh step sets the final position of the mesh.  During this step, the internal body meshes are generated 
according to a Laplacian smoothing process. At the same time, all cells are checked for distortion and adjustments are 
made according to the specified options. 
To use this option: 
a. Examine the surface mesh for last minute alterations. 
b. If the mesh is acceptable, select this option. 
This option can also be used if the user changes the mesh options (e.g. removed the hybrid or tetra option). Since 
these meshing options require no additional surface re-projection, a re-processing of Step 3 will immediately generate 
the mesh of the specified mesh type.  

Reset FlexMesh Control and Data 

Reset FlexMesh 

Selecting this option cleans up any current FlexMesh process and releases any memory that it is using.  All FlexMesh 
data and objects are released and the memory associated with them is freed.  This option is usually used when 
starting a new FlexMesh process or to clear FlexMesh data when reading in new FlexMesh data from a FlexMesh file. 

 

FlexMesh Attribute Control 

FlexMesh Attribute Control 

The FlexMesh Attribute dialog is used to assign an attribute value to selected cells or cell points.  When assigned, 
AMPSolid will transfer the assigned attribute value to the current OLE server module during the FlexMesh mesh export 
stage.  The attribute enables you to attach either boundary conditions or material data to the mesh.  For convenience, 
the FlexMesh Display control is automatically show on the screen at the beginning of the FlexMesh mesh export 
process. 
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This dialog provides several options: 
5. Initialize the attribute to ALL of the cells or cell points: Select this option if you want to initialize the cells to an 

attribute value as shown in the edit box.  The Action Type selection button determines whether this assignment is 
applied to cells or cell points. 

6. Assign attribute to the displayed cells/cell points: When using this option, displayed cells or cell points are 
assigned the currently specified attribute value.  You can use the options on the FlexMesh Display Control dialog 
to control the display region. 

7. Highlight cells/cell points with the specified attribute value: Using this option shows you any cells or cell points 
with the specified attribute value. 

8. Assign the attribute to the selected cell point: When using this option, displayed cell points are assigned the 
currently specified attribute value. The cell point selection vertex should be turned on before using this option. 

FlexMesh Cell Refinement Control 

FlexMesh Cell Division Refinement 

The FlexMesh Cell Division dialog enables you to break up a single cell plane into multiple cell planes.  A cell plane is 
defined as a collection of cells with the same relative index level in any WCS direction.  For example, the first X 
direction cell plane refers to the set of the first cells encountered along the WCS X direction in your model. 
To use this dialog, specify the cell plane to be divided by selecting the two end points of a cell side. The direction of 
your selection along that side determines the cell plane direction. All cells on that cell plane will be broken into the 
number of cells specified in the FlexMesh Cell Division dialog.  
 

 

FlexMesh Cell Merging Control 

The FlexMesh Cell Merging control enables you to eliminate unnecessary cells; specifically those along multiple cell 
planes. A cell plane is defined as a collection of cells with the same relative index level in any WCS direction.  For 
example, the first X direction cell plane refers to the set of the first cells encountered along the WCS X direction in your 
model. 
To use this feature, specify the cells to be merged by selecting the two end points of the connected cells. These two 
points must be the end points of a sequence of connected sides of the connected cells. The direction of your selection 
determines the cell plane direction. All cells on each cell plane between these two cell points will be eliminated and the 
adjacent two end cell planes are connected and merged into one. By default, the new plane will be located in the 



3D FlexMeshl Hexahedron Mesh Generation 

71 

middle of the existing space.  You can also use the optional New Cell Plane Position dialog to specify whether a new 
cell plane will be positioned at the high or low position of the selected end points. 

 

 

Remove Two-Face Surface Cells 

Two-Face cells are cells with at least two surface faces.  The FlexMesh process identifies a surface face by noting that 
there are no neighboring cell connecting to a face that is active.  Normally, two-face cells indicate an interior angle that 
is wider than desired, especially in the case of very flat surfaces.  In the case of concave-inward surface, such faces 
will generally form an angle wider than 180 degrees. By removing this type of cells, the quality of the mesh is 
preserved.  Be careful when using this option, because this scheme will the internal date structures that house 
information about these cells, which could prevent further FlexMesh operations.  You should only use this option after 
FlexMesh Step 3 has been completed, and as a last resort of improving the mesh quality. To be safe, you should save 
your current model and FlexMesh data before using this option. 
To use this option, select a common cell point on the two exterior surfaces of a cell, and select the WCS direction 
which identifies the cell array to remove.  The two neighboring cells will then be connected once the cell array is 
removed. 

FlexMesh Display Control 

FlexMesh Display Options 

These cell point and cell display controls provide options for use when displaying the current cell state. 

 
 
Pickable Cell Control Points : This option turns on the display handle for selectable 3rd order Lagrangian control 
point so you can select and position them. 
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Pickable Cell Points: This option turns on the display handle for cell points that can be selected and moved.  This is 
provided for cell plane, cell line, or cell point position adjustment. 
Show Bounding Box: This option turns on the display handle for the bounding box cell points that can be selected 
and moved.  This is mainly for fine position adjustment of the bounding box after you have finished cell control point 
adjustment.  
Show Interior Cell Sides: This option displays the internal cell sides for visual examination. 
Show Surface Cell Sides: This option displays the surface cell sides, and is active by default. 
Show Surface Cell Shaded: This option displays the surface cell faces in a shaded fashion to simplify inspection. 
Show All Cell Points: This option displays all active cell points that will be used in mesh generation. To avoid mis-
selection, these points do not have graphically selectable handles by default. 
Show Distorted Cells: This options displays a dialog box to allow further details controls of distorted cells display. 
Cell and Cell Point Display Control  
In some complex models, it is necessary to be able to display only a portion of the cells and/or cell points to make the 
display more manageable.  The FlexMesh Display Control dialog enables you to restrict the cells or cell points that are 
displayed at any point in AMPSolid. 

 
The FlexMesh Display Control lets you select a specified region by using the cell point index control in three WCS 
directions.  Selecting the "Dir X" check box indicates that the cell index filter in that WCS X direction is active. The cell 
index filter is specified by assigning a specified number in the edit boxes, or by using the thumbnail 
increment/decrement control.  
This dialog also provides two optional features: 
Auto Fast Display: This option is active by default, and automatically turns off the cell point selection vertex in order to 
improve the display refresh speed. 
Cell Display: When active, this option prevents the display size from shrinking to be smaller than a cell.  This enables 
you to use this panel as a cell display filter, e.g. in when assigning cell attribute to cells. 
 
 
 

Toggle Cell Pts/Show Feature Pts 

A feature point is a cell surface point that has 3 or 5 neighboring surface cell points.  If the "Feature Point Only" option 
is enabled during FlexMesh Step 2 processing the FlexMesh process will only assign geometric vertices to these 
feature points.  It is sometimes desirable to assign a regular surface cell point to be a feature point, so that the vertex 
sniffing process can have more degrees of freedom in making optimal choices. 
To use this option: 
a. Select the surface cell points to be assigned to be a feature point, or the disabled feature points to be activated 
b. Select this option. 
c. The state of the selected feature points is toggled. Currently disabled feature points in the selection will be 

enabled and highlighted, while currently enabled feature points in the selection will be disabled. 

Toggle Vertex/Show Disabled 

Because your geometry may contain various vertices that are not of interest from a modeling viewpoint, this option 
enables you to selectively disable specific vertices from being considered during FlexMesh processing. 
To use this option: 
a. Select the geometric vertices to be disabled or the currently disabled vertices to be enabled. 
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b. Select this option. 
c. The state of the currently selected vertices is toggled. Currently disabled vertices in the selection will be enabled 

and highlighted, while currently enabled vertices in the selection will be disabled. 

Toggle Edge/Show Disabled 

Because your geometry may contain various edge features that are not of interest from a modeling viewpoint, this 
option enables you to selectively disable specific edges from  being considered during FlexMesh processing. 
To use this option: 
a. Select the geometric edges to be disabled or the currently disabled edges to be enabled. 
b. Select this option. 
c. The state of the selected edges is toggled. Currently disabled geometric edges in the selection will be enabled 

and highlighted, while currently enabled edges in the selection will be disabled. 

FlexMesh Shading Display Control 
To speed up the graphic display, AMPSolid displays the cell mesh that is visible from the view point.   Sometime it is 
desirable to view both sides of the mesh with the light shading using this option to enhance the visibility.  To use this 
option, click the menu to turn on the check mark. 
 
 

FlexMesh Show Distorted Cells 

FlexMesh distortion display control is based on rapid internal cell mapping calculations. This control enables you to 
examine and highlight cells that are too distorted and which therefore may require some refinement.  You can select 
distorted cells by the interior angle (in degrees), a deviation check, a tiny cell side check, or by a cell aspect ration ratio 
check. The Invalid Jacobian Mapping checks the element and highlight element with bad Jacobian determinant values 
– or elements with illegal mapping. 
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Exporting FlexMesh Mesh 

Export Mesh 

The Export Mesh command allows you to generate the files necessary to set up a FEA problem using AMPView. 
Based on your method of mesh creation, the element type (2-D or 3-D) should already be specified and cannot be 
changed. The steps for exporting a mesh are: 
6. Complete the mesh using the AutoMesh menu or the FlexMesh menus. 
7. Select Files>Export Mesh to bring up this dialog. 
8. If 2nd order elements are desired, select Generate 2nd Order Lagrangian Elements. 
9. If creating 2D elements in the xy plane, Uncheck Generate 3-D Shell Elements. 
10. Click OK, and enter a filename in the next dialog for the AMPS FEA files (.dat, .fe, .geo) 

 
 
Use current .dat if mesh renamed and no .dat option (Default checked) 
After the first analysis of a model, it is informative to reanalyze the model using a different mesh. It is also useful to use 
a different name for the 2nd analysis so that the results can be easily compared. If this option is checked, and you 
export a new mesh using a different name for which no .dat file exists, the .dat file (FEA data) for the current model is 
copied for the new model so that forces and boundary conditions can be reused. 
If this is not checked and you save the mesh under a different file name that doesn’t have a .dat file, a minimum .dat 
file is created with geometry type (2D, Shell, 3D etc.) information but no FEA material or boundary condition 
information. 
If a .dat file already exist for the target mesh file name, you are given an option to use that file regardless of this 
setting. 
Generate 2nd Order Lagrangian Elements 
Whether you are generating 2D, 3D or shell mesh, you have the option to generate the 2nd order Lagrangian family 
elements.  If this option is not activated, the default 1st order elements are generated. 
Generate 3-D Shell Elements (Uncheck for 2D) 
If you generated a 2D or Surface mesh, you have the option of generating either a 2D mesh (the model must be on the 
global XY plane) or a 3D shell mesh (the grayed out "Generate 3-D Shell Elements" choice will be active). 
If you used FlexMesh to create the mesh 
Create the Cell mesh by completing FlexMesh step 3. Or if you are performing FlexMesh 2D task, finish the 2D or shell 
meshing. 

Export Mesh Details 

Other than generating the generic *.fe finite element data file defining nodes and elements, AMPSolid also generates 
an initial AMPSol finite element model definition file *.dat and a geometry database *.geo file. These two files are used 
for AMPSol  finite element model’s system control, material definitions, h-/p-adaptivity, boundary conditions, and 
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geometry connection to the solid model.   For more information about these files, please consult the on-line reference 
manual in AMPView. 
The Export Mesh option enables you to save your mesh once it has been generated. You can save your mesh after 
the FlexMesh3D’s FlexMesh Step 3 has been completed automatically or manually, or you have finished the FlexMesh 
2D/Shell mesh generation. 
AMPSolid uses OLE automation to invoke a MeshSvr server that is used to write the Finite Element mesh. Separating 
the application used to write the mesh from the basic AMPSolid application makes it easy for you to automatically 
invoke specialized mesh generation utilities for use with AMPSolid. When a version of MeshSvr is registered into your 
system, and it is activated, it will show up the ID with it’s proper title as below. 
AMPSolid includes the sample MeshSvr project that was created using the Microsoft Visual C++ wizard to implement it 
as a full stand-alone server. This server outputs mesh data in generic format currently formatted for AMPSol 
processor, and can easily be modified to export mesh data in other FE formats.  For additional information of exporting 
the mesh to other popular commercial FEA codes, please contact AMPS Technologies Company for available version 
of MeshSvr server for different FEA codes. 
 

AMPSolid Mesh Server 

The MeshSvr mesh server defines three OLE server functions that give you access to the mesh data created in 
AMPSolid. You can modify these subroutines to output the data in any format that you desire. 
The complete MeshSvr source code, by default, is installed under the AMPS product installationation directory. You 
can find the complete MeshSvr project in the MeshSvr directory. 
As in all Microsoft server programs, you must register the MeshSvr.exe program in the Windows registry if you modify 
it in any way. You can do this by simply executing the MeshSvr.exe application before attempting to use it with 
AMPSolid. The name of the registry entry associated with the MeshSvr.exe server is MeshSvr.Document. You can 
create your mesh export server in any language as long as you use the exchange format defined in the three 
subroutines, and as long as your server is registered with the name MeshSvr.Document. 
The server’s dispatch functions are defined in the files meshSvrDoc.cpp and MeshSvr.odl and can be modified by the 
user. You must then recompile the modified functions and link them in the MeshSvr project.  
The current dispatch functions can be easily modified to generate input data file to a user's finite element program, or 
to any popular commercial finite element programs. Since the MeshSvr server program is provided in a source code 
format, it is very easy to change the format. AMPS Technologies Company and the distributors usually can provide a 
different MeshSvr program for popular finite element code input format, such as NASTRAN bulk data deck writer. For 
more information about these, please contact the our technical support. 
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Recent Features or Changes 

Version 3.00 Changes 

There have been significant changes for AMPSolid version 3.00. 
 
The SCC Dialog (See Status and Cursor Control) 

• WCS checkbox so Position and Vector can be specified in the current Working Coordinate System (WCS) 

• Enter pos button to enter the current position as if it were a point clicked by the mouse 

• Enter Vec+P button to enter the current position plus the current vector position. 

• Shift (+CTRL) is necessary to copy the snap point to the SCC position value when the mouse is moved. 

• Len (vector length) moved before the vector. Entering zero as the length resets the vector to 0. 

• Tab and Enter can be used to enter points using only the keyboard. 
 
Snap Entry 

• The Snap cursor (a large +) is independent of the mouse cursor. 

• CTRL + Right Mouse Button (see Keyboard Shortcuts) can be used to snap to the closest vertex to the 
mouse cursor. The CTRL + Right Mouse Button works regardless of the current SCC CTRL Snap state. 
Right Mouse vertex snapping is disabled for Spline and Polyline entry where the right mouse button is used 
to terminate the current curve. 

 
Menu Changes 
Menu items have been moved to make it clearer which commands construct objects and which commands modify 
objects. The current menus are: 

• Edit This menu contains selection, point entry options and modifications that don’t change shape of the 
selected entities (e.g. cut, past, rigid translation, rigid rotation, color changes etc.). 

• Create This menu is for creating new entities. Commonly used methods are located on the top menu. Less 
common creation methods are on nested menus. The entitie creation methods are grouped from Vertex to 
Solids. 

• Modify This menu contains operations that modify the shape of existing entities. It includes the Boolean 
operations and various entity specific operations followed by modifications on wires, surfaces and solids. 

• AutoMesh This menu contains all the automatic meshing operations. Users who don’t need to learn about 
FlexMesh can do all their meshing using this menu. The first three options lead to essentially the same 
dialog. For Pre-Solid, the mixed and quad options are disabled because they should not be used.  

• FlexMesh/Surface This includes all the FlexMesh operations necessary to mesh surfaces in 3 dimensions. 

• FlexMesh/Solid This includes all the FlexMesh operations necessary to mesh solids. 

• View The View menu contains all the options for changing the view of the model and what is included in the 
model view window.  

• Options This menu contains general program options, SCC and toolbar visibility and a few orphan 
commands I don’t understand. 

Entering Surfaces 
Surfaces have been greatly simplified in this version. All surface creation commands create two-sided sheet-bodies. If 
the Create>Solid by stitching surface command is used, the surfaces are automatically adjusted so that the correct 
side faces in. It is no longer necessary to convert curves to wire-bodies for surface creation operations. All surface 
construction methods accept the following edge entity types: 

• Curves: Lines, Arcs, Splines created from the Create menu. 

• Edges of surfaces: Edges of existing surfaces. 

• Edges of solids: Edges of existing solids 

• Wire-bodies: Created by combining connected curves. 
Any selection order for Create>Cover Closed Curves and Modify>Curves to WireBody 
The curves used to form a covered surface may be selected in any order. If convenient, box selection may be used to 
select the curves. The curves to form a WireBody may also be selected in any order. 
Undo/Redo and Use Model History 
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• Undo/Redo: Geometric object creation and modification is recorded in a history list. The user can use Undo 
and Redo to change the model to a previous state and back. 

• Use Model History: If this File menu option is used to both save and later load a file, the user can undo 
operations performed in a previous session. 

• WCS operations independent of Undo/Redo: Changes to the WCS are independent of the undo/redo 
menu. Users can retrieve any previous WCS created during the current session using the Previous WCS 
and Next WCS options on the WCS dialog. 

Translate and Rotate added to Measure toolbar 
To make it easier use the common options and to make it easier to translate objects after measuring distances in the 
model, toolbar buttons for these operations have been added to the Measure toolbar. 
Cutting planes based on the ISO view 
A cutting plane toolbar allows users to view the insides of a model by including cutting planes. 
Different Cursors for different actions 
There as a plus cursor used for all construction operations and various other cursors used for selection, dynamic 
viewing, WCS changes and measuring. 
View, WCS and Measure commands are Toggle commands 
These commands can be performed during the construction of geometric entities and then toggled off so that the 
construction can be continued after changing the WCS, View or measuring distances. 
Modify: Trim curves>Fillet and Solid Modification>Blend Edges 
These now use the SCC vector X component as the fillet radius instead of the length. This corresponds to the blend 
edges help. The SCC vector length is kept consistent with the X, Y, Z values. So the length cannot be non-zero if all 
the values are zero. The vector X value can be changed independently. 
Files>Export Mesh 
This option includes a new checkbox: Use current .dat if mesh renamed and no .dat option.  If this option is 
checked and a different name is used for the exported mesh and no .dat (FEA data) file exist for the new name, then 
the .dat file from the current model is copied to the new name. This saves the user from manually copying the original 
.dat file when he wants to re-analyse a model using a different mesh (and a different name). 
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